Blob field not showing up in AGOL Map

994
3
Jump to solution
10-27-2016 11:24 AM
ChayaBalsiger
Occasional Contributor

I created a comment field with the field type as Blob in the RoadBlock feature class that is the Local Government Model.  I gave it a length of 1500.  I needed to create this field because I need to add comments longer than 255 characters. I published the service, created an editing map in ArcGIS Online, added test data, typed information in the comment field (field type Blob), saved the map and then refreshed the map.  After I refresh the map, I check to see if all the data is there; everything shows up but what was written in the comment field.  Whatever I type into the comment field does not get saved like the other data does (date, name, reason type etc).  Does the blob field type not show up in ArcGIS Online?

0 Kudos
1 Solution

Accepted Solutions
MarkHoyland
Occasional Contributor II

Could you use a string field with a length of 1500 instead of blob? You can have string fields with that length.

View solution in original post

3 Replies
MarkHoyland
Occasional Contributor II

Could you use a string field with a length of 1500 instead of blob? You can have string fields with that length.

View solution in original post

ChayaBalsiger
Occasional Contributor

That's what I did.  Now it works fine.

KatieCullen
Regular Contributor II

As Mark Hoyland states for this use case you would want to use a text field with a length of 1500. Blob fields store data in binary. Because blob fields store data in binary it would not be useful for storing comments which are intended to be readable by humans.

0 Kudos