Attribute Table and Pop-ups show in Map Viewer but not in Web App Viewer

2635
6
06-28-2016 10:32 AM
StevenDouglas4
New Contributor II

I am having trouble with attribute tables and pop-ups in the Web App builder viewer.

I have two (of many) layers (MapServer) that I've added in the Map Viewer. When I'm in the map viewer I have enabled and configured pop-ups and they show up. The attribute table also displays how it should in the Map Viewer.

However, when I am in the Web App viewer the pop-ups say "No Information Available" and the attribute table opens but is completely blank (the fields don't show up at all).

It is odd because all of the other layers in my Map viewer and App work fine.

Here is the link to the service if you'd like to try: microbio_geochemistry/decadal_precipitation (MapServer)

Does anyone have ideas?

0 Kudos
6 Replies
JayantaPoddar
MVP Esteemed Contributor

Did you follow the steps of configuring the Attribute table widget of WebApp Builder. Attribute Table widget—Web AppBuilder for ArcGIS | ArcGIS

and configuring popups in WebApp Builder

Configure pop-ups—ArcGIS Online Help | ArcGIS



Think Location
0 Kudos
StevenDouglas4
New Contributor II

Yep.

Like I said, all the other layers in the Web Builder work for pop-ups and attribute tables. And the pop-ups and attribute table works in the map view.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Did you take a look at the web traffic?  If I add the service to a webmap, enable popups and query, I get a 404 response for the following request:

http://olga.er.usgs.gov/stpgis/rest/services/microbio_geochemistry/decadal_precipitation/MapServer/1...

If you take out the outFields, you get a response back, so the USGS may be doing something to requests with certain characters in the request or a specific request length.  Do you see a 200 response code for your query request?

0 Kudos
StevenDouglas4
New Contributor II

I'm not sure about all that, but I went ahead and simply deleted the service and republished the layer from scratch. That seems to have fixed the problem.

0 Kudos
DerekLaw
Community Moderator

Hi Steve,

I tested with the sample REST endpoint your provided,

microbio_geochemistry/decadal_precipitation (MapServer)

and was able to define pop-ups in the web map, which are honored and visible in Web AppBuilder. I can also see their attribute tables in the Attribute Table widget. Please see demo app here,

ArcGIS Web Application

Hope this helps,

0 Kudos
StevenDouglas4
New Contributor II

I finally just deleted the service and republished it again. That seems to have fixed the problems. I still have no idea why.

0 Kudos