Select to view content in your preferred language

ArcGIS Online Summarize Within - length units only

624
5
09-09-2023 01:07 PM
Chris_Sutton_WIU
New Contributor II

In going through the Solve a Spatial Problem tutorial, when attempting to run the Summarize Within analysis tool, the Calculate statistics section allows only for Summarized length units, not Summarized area units. Specifying a linear unit causes the tool to fail.

calculate statistics.png

0 Kudos
5 Replies
AmandaRing
Esri Contributor

@Chris_Sutton_WIU 

Are you sure that the input features layer you selected is a polygon layer? I would expect the Summarized length units to only appear when summarizing polygon features.

Can you send a screenshot of the full tool parameters you are using, and confirm the steps you followed? Hopefully that can help us track down what is going wrong.

Cheers,

Amanda
Product Engineer - Web Analysis
0 Kudos
Chris_Sutton_WIU
New Contributor II

Hi Amanda,

Thanks for the replay. Well, I'm baffled. As a bit of helpful(?) information, I'm at Western Illinois University. We have two AGOL portals set up here. One is the "main" (original) site license (which our GIS Center administers) and the other is one that was set up specifically for use in our classes (called "wiuclass"). When I ran the tutorial I did it from the Admin account for wiuclass. Each time I run Summarize Within, I get the same issue that I originally reported (lengths being the only option).

HOWEVER, I ran the tutorial again from an account with the GIS Center (wiuhighwayman), and it worked just fine.

I went back in and logged into wiuclass with a non-administrative account and was only to get length units when doing Summarize Within. I ran the steps multiple times, starting from scratch to confirm & it repeated.

So now I'm thinking the glitch has something to do with how wiuclass is configured (which our University Technology folks work with Esri on). I'm on the teaching end of things, so whatever this is, it may be beyond my skill set, having to do with licensing(?).

Cheers,
Chris

0 Kudos
AmandaRing
Esri Contributor

That is quite odd. I recommend you contact Esri Support, who will be able to hop on a screenshare with you and hopefully better troubleshoot what is going on.

Amanda
Product Engineer - Web Analysis
CJ_Panorama
New Contributor

This is still a problem. I'm trying to summarize a polygon dataset using the Summarize Within widget. With the polygons set as the input features, the "Calculate Statistics" panel has a required parameter of "summarized length units". I would think it should say area units instead. The tool then gives an error "The shape units Miles are not valid when summarizing a Polygon layer".

0 Kudos
AmandaRing
Esri Contributor

Thanks @CJ_Panorama and @Chris_Sutton_WIU for reporting this issue.
We think we've been able to figure out what's going wrong and will fix it in the next update to ArcGIS Online. In the meantime, the issue can be resolved by ensuring that a unit system is selected either for your current user or for your organization as a whole.

If you have the default administrator role or a custom role with the appropriate administrative privileges, you can set the units for their organization by going to Organization > Settings > Map > Map Defaults > Units.
Then switch to Metric, or switch to Metric and then back to US Standard, depending on your preference. You should see a notice at the bottom of the screen that the Units have been updated successfully.
Learn more here.

AmandaRing_1-1699904119538.png

 


If you don't have an administrator role, you can configure the unit settings for just your user. Once you are signed in, click your name in the banner at the top of the site, and click My settings. On the General tab, scroll down to units and select either US Standard or Metric, depending on your preference. You should see a notice at the bottom of the screen that the Units have been updated successfully.
Learn more here.

AmandaRing_0-1699904029018.png

 

Please give either of these a try and let me know if it doesn't resolve the issue.
Sorry for the inconvenience, and thank you again for letting us know about it!

Cheers,

Amanda
Product Engineer - Web Analysis