ArcGIS Online - Error: edits could not be saved

1974
5
03-01-2022 02:27 AM
Kantoor__DataCount_-_Verkeerso
New Contributor III

Hello everyone,

I'm having the following error while editing data that's been uploaded recently: Oops, something went wrong, Edits could not be saved error. 

Kantoor__DataCount__Verkeerso_0-1646129973588.png

 

The features are editable cause these settings were on:

Kantoor__DataCount__Verkeerso_1-1646130162191.png

It doesn't help to load the data in a new map. Weird enough it is possible to edit the data while loading in Map Viewer Classic without having this error. So it seems to be a Map Viewer problem. Is somebody else issueing the same problem?

Regards, Marius

 

 

 

 

0 Kudos
5 Replies
ABishop
MVP Regular Contributor

Hello,

At first glance I would say to check off the "Add" and "Delete" and possibly the "Update" check boxes?

ABishop_0-1646143333447.png

 

Amanda Bishop, GISP
0 Kudos
Kantoor__DataCount_-_Verkeerso
New Contributor III

Thanks Amanda, for your reply!

We tried your suggestion, but that doesn't fix the problem. When all boxes are unchecked, the edit modus in the Map Viewer turns off as it should. When the boxes are checked again, the same errors appears when we try to save edits. Therefore, it seems like it's not related to the kind of edit options.

As said before the problem only appears in the new Map Viewer, in the old viewer it is possible to edit the data.

Kind regards, Frank

0 Kudos
ABishop
MVP Regular Contributor

When you initially published this service did you make sure the feature edit options were checked?  

Amanda Bishop, GISP
0 Kudos
Kantoor__DataCount_-_Verkeerso
New Contributor III

Yes, we did, but that didn't fix our problem.

However, we did find the solution: a textfield had '<Null> written as text, instead of a real Null-value. By recalculating the values to a real Null, we managed to save our edits.

Thanks for your help!

Kind regards, Frank

BrookeAumann
New Contributor III

Thank you for this! I was having a similar problem and this was the issue.

0 Kudos