Select to view content in your preferred language

ArcGIS Online App Builder layers greyed out in layer list and not displaying in Edit widget

563
2
Jump to solution
07-27-2023 02:42 PM
CharlescobBailey
New Contributor III

Hello, I have an app with a layer list and Edit widget. Two of the layers are greyed out and do not display in the edit widget dialog. In the web map that runs the app, they show up in the edit tab just fine. They are also greyed out in the TOC of the web map but display in the Edit tab. I saved it in a different browser and they are not greyed out, but when I open from AGOL they are. What gives? Thanks a lot - cob

0 Kudos
1 Solution

Accepted Solutions
CharlescobBailey
New Contributor III

Yes, what happened was the layers were not owned by me and were saved with scale dependencies. They had to be removed entirely to fix. Even when you were within the range of display, it still wouldn't show up in the app or editing widget. Another bug. Thanks, cob

View solution in original post

2 Replies
David_McRitchie
Esri Contributor

Hey Charles,

This sounds a bit unusual that it is giving different behaviour in different web browsers. Can we confirm that the editing settings are enabled for the layer under the settings page?

 

editsettings.png

 

Many thanks,

David

Esri UK -Technical Support Analyst
0 Kudos
CharlescobBailey
New Contributor III

Yes, what happened was the layers were not owned by me and were saved with scale dependencies. They had to be removed entirely to fix. Even when you were within the range of display, it still wouldn't show up in the app or editing widget. Another bug. Thanks, cob