AGOL popup appending portal URL onto hyperlinks

549
4
Jump to solution
03-20-2019 10:05 AM
Kara_Shindle
Occasional Contributor III

I just ran into this issue, and I was wondering if this was a organization security setting.

I am working in two AGOL accounts.  One is my own that I administer, and I have no problems with the pop up URLs, they work as they should (i.e. I create a custom popup and specify an attribute as my website link, & voila! popup has a nice link to an outside URL that works fabulously).

The second AGOL account is for an organization and I am a user who can create web maps.  But creating a popup with a custom website URL results in it appending the organizations portal URL to the beginning of whatever website I have in my attributes. 

i.e. "www.google.com" in the attributes becomes "<organization>.maps.arcgis.com/home/webmap/www.google.com"

My only guess is that it is a security setting...

Since I do not administer the second account, they are asking what setting they need to fix in order for the popup URLS to work properly.  

Anyone have any ideas?

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

What does the exact value of your link look like? Are you just using "www.google.com" (for example) and not adding the http or https?

View solution in original post

4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

What does the exact value of your link look like? Are you just using "www.google.com" (for example) and not adding the http or https?

Kara_Shindle
Occasional Contributor III

I am just using www.google.com for an example.  I received this data and it appears that all of the web addresses start with www.

0 Kudos
Kara_Shindle
Occasional Contributor III

Your question got me looking at the web addresses, and creating an arcade expression to concatenate the http / https onto the addresses fixed my issue.  Thanks for the boost!

0 Kudos
KellyGerrow
Esri Frequent Contributor

Can you share your web map?

0 Kudos