Select to view content in your preferred language

Change HTML Connection Location Enterprise

349
4
02-07-2024 12:07 PM
CodyPatterson
Regular Contributor

Hey all,

Recently, we've been experiencing an error related to our Notebook environment not being able to connect to our portal. It gives us this error here:

ConnectionError: A connection error has occurred: HTTPSConnectionPool(host='arcgis.domain.com', port=7443): Max retries exceeded with url: /arcgis/sharing/rest/portals/self (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x7fc6702aeb80>: Failed to establish a new connection: [Errno 113] No route to host'))

 

The only issue is that the host is not the actual host, where can we change this URL? This is after a re-federation as well. This occurs during the GIS = gis("home") process.

Would there be a config file somewhere?

Enterprise 11.2

Thanks in advance!

0 Kudos
4 Replies
shikhar_deep
Esri Contributor

Hi @CodyPatterson 

Can you share the federated server site details of Notebookserver from Organisation-> Settings->Server [Service and Administration url] ?

Thanks
Shikhar Deep

0 Kudos
CodyPatterson
Regular Contributor

Hey @shikhar_deep 

I apologize for my lack of knowledge, but I assume this is taken from the Notebook server, is this through the rest/services location or the admin location? I can't seem to find the server site details you're mentioning.

Thank you,

Cody

0 Kudos
shikhar_deep
Esri Contributor

Hi @CodyPatterson ,

It will be from the Portal home app. The base enterprise where the Notebook Server is federated.

 

Thanks & Regards

Shikhar Deep

0 Kudos
CodyPatterson
Regular Contributor

Hey @shikhar_deep 

I see what you mean now, not sure what I was thinking initially, but the Service and Admin URL appear to be the same, there's a hidden appending of /notebook/manager on the administration URL, but they are in this format: https://arcgis.domain.com/webadaptor instead of https://arcgis.domain.com:11443/arcgis 

Hope that helps!

0 Kudos