Breaks in my road network - how to fix that

307
3
02-16-2019 09:54 AM
VikasMenghwani
New Contributor

Hello,

On ARCGIS Pro 

I have a road network - on which I am performing a network analysis. I realize there are breaks in the network, which means some incidents and facilities cannot find each other. Is there any way I can fix the network? I tried the integrate tool but it fails - throws "invalid topology" error. Is there any way?  

Reply
0 Kudos
3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Run a Check Geometry and Repair Geometry if necessary

Do you actually have a topology?

Create a topology—Topologies | ArcGIS Desktop 

And you may have to do it old-school by joining disjoint road segments if all fails

Reply
0 Kudos
VikasMenghwani
New Contributor

Hi Dan,

Thanks for this. I created a topology but I do not know how to use it... it shows me in Arccatalog..how do I utilize that in network analysis?

Reply
0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Did you run through the first two steps?

Is your road featureclass error free

Did you check for dangles in the file? Common topology tasks—Topologies | ArcGIS Desktop 

if you have an appropriate license... what about extend line? Extend Line—Help | ArcGIS Desktop 

There is no 'automagic' solution that is going to fix everything, especially if you have no idea who, or how, the road file was created.

Errors exist in many datasets and grunt work may be the only solution to fixing the inability to traverse the network.  Isolate problem sections by doing quick origin destination tests