Better Bus Buffers Input error

469
10
Jump to solution
07-14-2020 06:21 AM
RaunaqSaboo
New Contributor II

Hi

I am working with GTFS dataset and I am trying to use the Better Bus Buffers toolbox. However, while using the preprocessing GTFS toolbox, I cannot upload the GTFS directory and cannot mention the location for output SQL database. I am using ArcGIS Pro. I am getting the following error:

ERROR 032659 Traceback (most recent call last):
File "<string>", line 94, in updateMessages
AttributeError: module 'ToolValidator' has no attribute 'check_input_gtfs' 

Any ideas on how to fix this?

Thanks in advance

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
RaunaqSaboo
New Contributor II

It worked after a software update. Seems like that was the issue

View solution in original post

0 Kudos
10 Replies
MelindaMorang
Esri Regular Contributor

Hmm, that's an odd error.  The ToolValidator.py module definitely has that function, and I just tested it on my own machine with ArcGIS Pro, and it's working fine.  My guess is that something happened to the BetterBusBuffers toolbox code on your machine.

Please delete your copy of BetterBusBuffers, including all the associated .py files, and download a fresh copy here: http://arcg.is/0yr9fr 

If you need to move it to some other location on your computer after downloading and unzipping it, be sure to move the entire parent folder so that all the associated scripts and other files stay together.

0 Kudos
RaunaqSaboo
New Contributor II

Hi Melinda, Thanks for your reply. I tried that but I am getting the same problem again. Is there any other fix?

0 Kudos
MelindaMorang
Esri Regular Contributor

Can you tell me what version of ArcGIS Pro you're using?

Also, are you running the tool from within Pro, or is it in a python script or a model or something?

0 Kudos
RaunaqSaboo
New Contributor II

I am using ArcGIS Pro 2 and I am running the tool from within Pro.

0 Kudos
MelindaMorang
Esri Regular Contributor

What number does it say on the About page?

0 Kudos
RaunaqSaboo
New Contributor II

It worked after a software update. Seems like that was the issue

0 Kudos
MelindaMorang
Esri Regular Contributor

Glad to hear it!  There was some issue with ToolValidator several Pro releases back, but I didn't know it affected this tool.  My apologies for your trouble.

0 Kudos
RaunaqSaboo
New Contributor II

Hi 
Turns out that the issue has arisen again. The software version is 2.5.2. The tool ran once successfully. However, this time the error is:

ERROR 032659 Traceback (most recent call last):
File "<string>", line 148, in updateMessages
AttributeError: module 'ToolValidator' has no attribute 'check_SQLDBase'

Any fix for this?

0 Kudos
MelindaMorang
Esri Regular Contributor

Here's something else to try.

  1. Close ArcGIS Pro if it's open.
  2. In Windows Explorer open the folder where your BetterBusBuffers files are stored.
  3. Delete the __pycache__ folder if it exists:
     
  4. Delete all files in that folder with a .pyc or .pyt.xml extension. Do not delete any other files.
  5. Try running the tool again.

If that doesn't fix it, let me know, and we'll keep trying.

0 Kudos