Select to view content in your preferred language

Bug: downloading Navigator MMPk greater than 3.4GB

565
10
Jump to solution
02-23-2024 06:26 AM
6w-nick
New Contributor II

I am having problems with ArcGIS Navigator when downloading AGOL mobile map packages (mmpk's) that are over ~3.4GB. 

For example when I try and download the Australia mmpk (7.6GB) using the android navigator app it starts to download, but reports that it is only 3.3GB in size, when it reaches 3.3GB downloaded it just fails with no errors.

When I try and download a smaller mmpk such as Western Australia (393.3MB) it successfully downloads.

I have tried downloading directly from AGOl and through ArcGIS Enterprise (hosting the files) with the same issue.

Strangely the MMPK packages download successful in Fieldmaps on the same device.

Screenshot_20240223_142012_Navigator.jpgScreenshot_20240223_142025_Navigator.jpg

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
DanielFox1
Esri Contributor

Hi @KerriRasmussen and @6w-nick 

I just wanted to let you know that a bug has been logged against this issue. BUG-000165738

View solution in original post

0 Kudos
10 Replies
KerriRasmussen
Esri Contributor

Thank you for your post and I'm sorry you are experiencing an issue with ArcGIS Navigator. Could you tell me more about the make/model of the device you are using? Also, have you tried this on any other devices and if so are you seeing the same behavior? 

0 Kudos
6WNickB
New Contributor

Hi Kerri, I have tried it on 2 devices so far, both with the same issue. The strange thing is if I download the maps in Fieldmaps I don't have an issue, the app is reporting the correct file size and successfully downloads. It appears to only be Navigator that has the issue.

Samsung S21 5G, Android 14, 220GB free storage.

Samsung S22 Ultra, Android 14, 300+GB free storage.

To make sure the mmpk files worked I did sideload some of the larger mmpk's and they worked as expected, unfortunately this isn't a solution for the project I am working on.

Thanks again

Nick

0 Kudos
6WNickB
New Contributor

Hi Kerri, further to my previous post I have now tried it on a Samsung Galaxy Tab S7 FE 5G and it has the same issue.

For some reason the app thinks the file size is different once a download has been started:

Australia - 7.9GB in Gallery but when downloading it reports 3.3GB

UK - 3.9GB in Gallery but 3.4GB when downloading.

Both files complete the 3.3/3.4GB downloads but then pop back in the gallery rather than the downloaded files.

I have create a screen recording.

0 Kudos
KerriRasmussen
Esri Contributor

Hi Nick,

Thank you for the additional information, it's very helpful. And thank you for testing on Field Maps as well, that gives us some additional insights. While Navigator and Field Maps are both ArcGIS mobile apps, they are two very different apps, so it's not completely out of the ordinary to see different behavior between the two. 

One additional question for you, are you using ArcGIS Online or ArcGIS Enterprise with Navigator?

Thank you,

Kerri

 

0 Kudos
6w-nick
New Contributor II

Hi Kerri,

In answer to your question I have tried both.

  • Using my Developer AGOL account directly.
  • Hosting files on a web server and registering them with ArcGIS Enterprise.

For some reason over around 3GB Navigator gets confused, small mmpk's download and run with no problems. I thought it was the formatting of the device not supporting large files, but side loading the mmpk's should have had the same problem.

I tried Fieldmaps mainly because I thought it might be my network causing the problem.

Thanks for responding so quickly.

Nick

0 Kudos
KerriRasmussen
Esri Contributor

Hi Nick, 

I recommend reaching out to Esri Technical Support to log this issue with them. I will also continue to work on this on my end. As you have seen, sideloading is a workaround for now, until we can get this sorted. 

Thank you,

Kerri

0 Kudos
6WNickB
New Contributor

Thanks Kerri, I will reach out to EsriUK and tag this post.

Nick

0 Kudos
KerriRasmussen
Esri Contributor

Great, thanks Nick. One more question for you, which version of Enterprise are you using?

Thank you,

Kerri

0 Kudos
6w-nick
New Contributor II

Hi Kerri, I am using AGOL and ArcGIS Enterprise 11.2

My support case is in with EsriUK.

0 Kudos