Monitor GeoEvent: ZKPersistenceUtility Error

434
1
06-01-2020 11:58 AM
TristanForward1
New Contributor

Monitor keeps getting the following error with GeoEvent with monitor, any ideas?

1 06/01/2020 2:49 PM com.esri.ges.fabric.internal.ZKPersistenceUtility ERROR ERROR KeeperErrorCode = ConnectionLoss for /geoevent/config/clusters/default/arcgisServerConnections/d51d8e71-5f1a-4814-8690-4a59f6c1741e.json/ServicesCache.json org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /geoevent/config/clusters/default/arcgisServerConnections/d51d8e71-5f1a-4814-8690-4a59f6c1741e.json/ServicesCache.json at org.apache.zookeeper.KeeperException.create(KeeperException.java:102) ~[403:org.apache.zookeeper.zookeeper-geoevent:3.5.4] at org.apache.zookeeper.KeeperException.create(KeeperException.java:54) ~[403:org.apache.zookeeper.zookeeper-geoevent:3.5.4] at org.apache.zookeeper.ZooKeeper.setData(ZooKeeper.java:2296) ~[403:org.apache.zookeeper.zookeeper-geoevent:3.5.4] at org.apache.curator.framework.imps.SetDataBuilderImpl$4.call(SetDataBuilderImpl.java:272) ~[?:?] at org.apache.curator.framework.imps.SetDataBuilderImpl$4.call(SetDataBuilderImpl.java:268) ~[?:?] at org.apache.curator.connection.StandardConnectionHandlingPolicy.callWithRetry(StandardConnectionHandlingPolicy.java:67) ~[223:curator-client:3.1.0] at org.apache.curator.RetryLoop.callWithRetry(RetryLoop.java:99) ~[223:curator-client:3.1.0] at org.apache.curator.framework.imps.SetDataBuilderImpl.pathInForeground(SetDataBuilderImpl.java:265) ~[224:curator-framework:3.1.0] at org.apache.curator.framework.imps.SetDataBuilderImpl.forPath(SetDataBuilderImpl.java:251) ~[224:curator-framework:3.1.0] at org.apache.curator.framework.imps.SetDataBuilderImpl.forPath(SetDataBuilderImpl.java:39) ~[224:curator-framework:3.1.0] at com.esri.ges.fabric.internal.ZKPersistenceUtility.writeToPath(ZKPersistenceUtility.java:233) [167:com.esri.ges.persistence.zookeeper.zk-persistenceutility:10.7.1] at Proxya9b9b01a_0f7a_4242_b5a4_11bcaf4f4f49.writeToPath(Unknown Source) [?:?] at com.esri.ges.persistence.zookeeper.agsconnection.ZKArcGISServerConnectionDAO.persistServicesInfo(ZKArcGISServerConnectionDAO.java:544) [156:com.esri.ges.persistence.zookeeper.agsconnection:10.7.1] at Proxydd4251ba_0851_48aa_b246_77328577e923.persistServicesInfo(Unknown Source) [?:?] at com.esri.ges.manager.datastore.agsconnection.internal.ArcGISServerConnectionManagerImpl.onArcGISServerConnectionStatusChange(ArcGISServerConnectionManagerImpl.java:817) [129:com.esri.ges.manager.internal-agsconnectionmanager:10.7.1] at com.esri.ges.datastore.agsconnection.DefaultArcGISServerConnection$CacheUpdater.update(DefaultArcGISServerConnection.java:190) [53:com.esri.ges.framework.datastore.agsconnection-datastore:10.7.1] at com.esri.ges.datastore.agsconnection.DefaultArcGISServerConnection$CacheUpdater.run(DefaultArcGISServerConnection.java:229) [53:com.esri.ges.framework.datastore.agsconnection-datastore:10.7.1]

https://community.esri.com/thread/205310-comesrigesfabricinternalzkpersistenceutility
https://community.esri.com/thread/192325-comesrigesfabricinternalzkpersistenceutility-connectionloss

0 Kudos
1 Reply
MichaelReither
New Contributor III

ArcGIS Monitor is only reading the GeoEvent log file and reporting what it finds. You should see the same error if you look directly in the GeoEvent logs from the Geoevent interface.

Check on the GeoEvent log in Geonet:

GeoEvent 

It appears a similar question was asked on the GeoEvent section of GeoNet but I don't see a solution - so you may need to open a case with Esri Support.   Make sure you have all the required GeoEvent patches installed.

https://community.esri.com/thread/205310-comesrigesfabricinternalzkpersistenceutility 

0 Kudos