Issue deploying ArcGIS Monitor

3134
12
Jump to solution
05-28-2018 04:56 PM
deleted-user-RhG9zFDAFTI1
New Contributor

Hi,

  I'm setting up ArcGIS Monitor here in our enterprise environment. I have had a Windows 2012 server deployed just for the purpose of trialling this software.

I ran through the installer without an issue. I then installed MongoDB v3.6. I configured the post install to point it to the Mongo path and port and set up the Mongo data path. I can access the System Monitor website from outside of the server.

The problem is when I run the ArcGIS Monitor Administrator I cannot make a connection. I'm using the tutorial here: Create a connection to ArcGIS Monitor Server—ArcGIS Monitor Administrator | ArcGIS Enterprise 

As ArcGIS Monitor server is installed on the same machine as ArcGIS Monitor Administrator I've been attempting to refer to it by localhost, 127.0.0.1, the machine name, and the machine alias, but still no luck.

Please let me know what to try next. Thanks.

Error

Error.

Post install

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
JohnGraham2
Occasional Contributor

Hi David, good to hear it's working. Yes, the default password ArcGISMonitor is case-sensitive.

If you need any further assistance with ArcGIS Monitor, I recommend contacting Esri Technical Support so an analyst could best support you.

View solution in original post

0 Kudos
12 Replies
GIS_Solutions
Occasional Contributor

I have to same issue, no one knows?

0 Kudos
AndrewSakowicz
Esri Contributor

Please use ArcGIS Monitor Server port, which is 443 in your case.

0 Kudos
deleted-user-RhG9zFDAFTI1
New Contributor

Hi Andrew, thanks for your reply. 443 give me this error:

I checked for open 443 ports on the server and got the following. I think TIME_WAIT indicates that the connection is present but closed?

0 Kudos
AndrewSakowicz
Esri Contributor

Please refer to:

ArcGIS Monitor system requirements—ArcGIS Monitor | ArcGIS Enterprise 

Firewall settings for Monitor Server

By default, Monitor Server communicates on port 443, and MongoDB communicates on port 27017.

Note:

If IIS is running on the machine, port 443 may already be in use and you will need to choose a different port number, such as 444.

If this is ArcGIS Monitor production system, please turn off IIS (or another application that users 443).  If this is dev and you'd like to use a different port, please refer to: 

Troubleshoot connection problems—ArcGIS Monitor Administrator | ArcGIS Enterprise 

0 Kudos
deleted-user-RhG9zFDAFTI1
New Contributor

Hi Andrew,

  IIS is not installed on the server we are using for GIS monitor.

If I run the ArcGIS monitor post install the options are greyed out and I am unable to modify them. I see that it writes to a file called "ArcGIS Monitor\Server\InitParams.ini". If I edit that file to change the port to 444 and then restart the service it seems to ignore it. I even tried restarting the server after modifying that file and ArcGIS Monitor is still using port 443.

Here is the file I can modify manually, but the service ignores it and uses 443 regardless.

0 Kudos
DavidColey
Frequent Contributor

Hi Andrew - I am encountering a token error when trying to make a connection, with the account Site and the password.  I am using

Name: 'Monitor'

Server 'localhost:443'

User 'Site'

Password: ??

How do determine what the password is for the Site account??

0 Kudos
JohnGraham2
Occasional Contributor

Hi David,

The default password is ArcGISMonitor. If you changed the password in the Post-Install step, you will need to use that password. If needed, you can reset the password. Refer the link below. http://enterprisedev.arcgis.com/en/monitor/latest/administration/reset-the-arcgis-monitor-server-pas... 

0 Kudos
DavidColey
Frequent Contributor

Hi John, thanks for the reply.  I did not change the password on the Post-Install step, as all the options were grayed out, just like in Mike's post below.  However, at this point I have completely removed monitor and mongodb and am going to try re-installing both.  The only thing I am doing differently is setting up the mongodb data path and logs to go to a D:\ drive as opposed to C:\ 

I can confirm that IIS is not installed and that mongo was listening on 27017, the port is not being blocked by firewall rules.

I can confirm that monitor was listening on 443.

Can you confirm that the defualt password ArcGISMonitor is case-sensitive just as you wrote above?

0 Kudos
DavidColey
Frequent Contributor

Hi John - After performing a new install of mongodb and monitor, I am now able to make a connection.

I'm not sure that this makes a difference, but on my production windows 2016 server where I am performing this install I gave explicit admin rights to the service account I use to log into the server with.  I also set the user account control to it's minimum setting. 

Pay close attention to the monogodb install instructions.  Be sure to leave open the mongodb engine up in the command prompt when setting up the mongodb windows service - mongo's instructions are a little tricky on that.

Once authorized, I was able to set the password and explicit paths on Post-Install.  Then I was able to make a connection to the server:

0 Kudos