ArcGIS Monitor Does not show any data

322
2
Jump to solution
11-25-2019 06:19 AM
ApurvDanke
Occasional Contributor

Hello,

We have been extracting reports from ArcGIS Monitor on a daily basis, monitoring ArcGIS Server and Portal for ArcGIS. Since last few days there is no data in the report. All reports are the same, and few tabs in the report excel sheet are missing. If I try to see graphs on the ArcGIS Monitor dashboard, I see a message "No data available".

Interestingly this is happening only for one of the collectors, the other collector is getting data correctly. Any suggestions on what could be the reason the collection is failing for one of the collectors?

Versions as given below.

ArcGIS Monitor 10.6.1

ArcGIS Server 10.4.1

Portal for ArcGIS 10.4.1

Regards,

Apurv

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
MichaelReither
New Contributor III

I assume that everything used to be working correctly (data was collected and you could see the data in the graphs).

Go into ArcGIS Monitor Administrator and drill down into that collector; pick an counter (System counter, ArcGIS counter) and click TEST to see if the test function works correctly. If not, trouble shoot the error message.

You can also look at one of the graphs and click the back arrow button; go back in time and find the last day/time when data was collected and use that info as a troubleshooting timestamp.

Check the service for that collector in Windows Services. Is it running?  Has the password been changed or expired for that service?  In theory the Windows account running the collector service should not expire.

View solution in original post

0 Kudos
2 Replies
MattD
by Esri Contributor
Esri Contributor

Hey Apurv,

Have you checked the logs for ArcGIS Monitor, namely the ReportServer.log file or the mongo.log file? You would want to take a look at these for information on the counter (potentially not connecting) or the database logs could indicate ArcGIS monitor failing to write the data.

You can generate a fresh log file along with all pertinent information using the support.bat method in the following article - Troubleshoot ArcGIS Monitor Server application problems—ArcGIS Monitor Administrator | ArcGIS Enterp... 

In addition to this, if you create a new counter does this issue persist?

MichaelReither
New Contributor III

I assume that everything used to be working correctly (data was collected and you could see the data in the graphs).

Go into ArcGIS Monitor Administrator and drill down into that collector; pick an counter (System counter, ArcGIS counter) and click TEST to see if the test function works correctly. If not, trouble shoot the error message.

You can also look at one of the graphs and click the back arrow button; go back in time and find the last day/time when data was collected and use that info as a troubleshooting timestamp.

Check the service for that collector in Windows Services. Is it running?  Has the password been changed or expired for that service?  In theory the Windows account running the collector service should not expire.

View solution in original post

0 Kudos