Upgrade to JS 4.25 and Calcite 1.0.3 throws ResizeObserver.<anonymous> error (whatever that is)

733
4
Jump to solution
02-05-2023 03:26 PM
Dirk_Vandervoort
New Contributor III

Simultaneous upgrade from JS 4.24 and Calcite1.0.0-beta.97 now sends an error to the console when loading the JSAPI:

caught TypeError: Cannot read properties of undefined (reading 'style') at ResizeObserver.<anonymous> (p-3e421dc8.entry.js:6:3580)

The stack does not return any references to any of my code. There's a ResizeObserver API, but it's not clear how this relates to the JSAPI other than Calcite contains the script 3e421dc8.entry.js

Dirk_Vandervoort_1-1675639528513.png

Anyone else seeing this or have a fix? 

TIA

0 Kudos
1 Solution

Accepted Solutions
ReneRubalcava
Frequent Contributor

Looks like this is an issue with calcite, and not the Maps SDK. According to this issue, the fix is available in 1.0.4-next.4 release.

https://github.com/Esri/calcite-components/issues/6310

So you can try the calcite "next" build for now until the next production release.

View solution in original post

4 Replies
ReneRubalcava
Frequent Contributor

4.25 was built using 1.0.0-beta.97, lots of changes to version 1.0.3. Are there particular widgets you are using that cause this error? The "next" version of the API uses calcite-components 1.0.3, can you try that and see if the error persists?

https://www.npmjs.com/package/@arcgis/core/v/4.26.0-next.20230205?activeTab=explore

Dirk_Vandervoort
New Contributor III

Hi Rene:

Are there particular widgets you are using that cause this error? I have identifed the HTML that causes the error:

    <calcite-card id="tool-container">
        <calcite-tabs>
            <calcite-tab-nav slot="title-group">
                <calcite-tab-title selected>Navigation</calcite-tab-title>
                <calcite-tab-title>Appearance</calcite-tab-title>
            </calcite-tab-nav>
            <calcite-tab selected>
                <div id="navigation-container"></div>
            </calcite-tab>
            <calcite-tab>
                <div id="appearance-container"></div>
            </calcite-tab>
        </calcite-tabs>
    </calcite-card>

in particular the declaration: 

<calcite-tab-nav slot="title-group">

I'm still trying to figure out what's up with calcite-tab-nav.

can you try that and see if the error persists? The error persists at 4.26.

 

0 Kudos
ReneRubalcava
Frequent Contributor

Looks like this is an issue with calcite, and not the Maps SDK. According to this issue, the fix is available in 1.0.4-next.4 release.

https://github.com/Esri/calcite-components/issues/6310

So you can try the calcite "next" build for now until the next production release.

Dirk_Vandervoort
New Contributor III

Yep, Calcite. We're not ready for 1.0.4-next.4.

Thanks Rene!

0 Kudos