Layer List - Item Panel - Expand/Collapse button has no tabindex

1717
4
Jump to solution
08-28-2023 10:00 AM
Jeff-Reinhart
New Contributor III

Hi everyone!

Running into some trouble with the LayerList in 4.27. Here is a codepen:

https://codepen.io/jeffreinhart/pen/WNLQxRJ

The SDK adds buttons to expand/collapse different items underneath each layer in the LayerList. It doesn't seem all of the expand/collapse buttons get a tabindex.

As you will see in the codepen, the button that gets created for item.actionsSections gets a tabindex. The button that gets created for item.panel does not get a tabindex. This greatly affects the keyboard navigation of the LayerList. Seems like a bug.

Can anyone confirm this is a bug?

Does anyone have a work-around to hang a tabindex on the button created for item.panel? I am having a rough time trying to point a querySelector or querySelectorAll at the buttons.

0 Kudos
1 Solution

Accepted Solutions
Sage_Wall
Esri Contributor

Hi @Jeff-Reinhart , We've installed a fix for this issue. It's available now using the "next" version of the API and will be part of the 4.28 release. I updated your original codepen to use "next" and keyboard navigation is working as expected.  Thanks again for reporting this.

https://codepen.io/sagewall/pen/bGOgReZ

View solution in original post

0 Kudos
4 Replies
Sage_Wall
Esri Contributor

Hi @Jeff-Reinhart this does indeed look like a bug that was inadvertently introduced at version 4.25. Reverting your codepen back to version 4.24 the proper tab index is present and the keyboard navigation works as expected. I can create an internal issue, but it would be great if you could submit a bug through technical support.  That way you'll be able to get updates.

0 Kudos
Jeff-Reinhart
New Contributor III

Thanks, @Sage_Wall. Would that "technical support" be through what we have at our organization or is there somewhere on the Esri Community that I can do that?

0 Kudos
Sage_Wall
Esri Contributor

Of course, Thanks for bringing this to our attention.  The easiest way to submit a bug through technical support is to fill out this form https://support.esri.com/en-us/contact/report-bug

0 Kudos
Sage_Wall
Esri Contributor

Hi @Jeff-Reinhart , We've installed a fix for this issue. It's available now using the "next" version of the API and will be part of the 4.28 release. I updated your original codepen to use "next" and keyboard navigation is working as expected.  Thanks again for reporting this.

https://codepen.io/sagewall/pen/bGOgReZ

0 Kudos