Select to view content in your preferred language

Error in retrieving records for table

246
2
Jump to solution
03-13-2023 07:23 AM
kapalczynski
Occasional Contributor III

I have a weird issue... I inherited an app that was created before my time.  

I can run the app and load all the layers.  There is a specific polygon layer in there that is only 733 records.  If I view the map at full scale and then open the attribute table it spins but then seems to time out as the records do not appear.  

If I zoom in a bit it loads the appropriate records from that zoom level but if I request all the records (only 733) it stalls out and give me the query error

 

Console says this

kapalczynski_0-1678717093576.png

Sources Says this:

kapalczynski_1-1678717130910.png

 

So I started thinking a time out or something....

This is the Service that is having the issues.... Although the error is thrown at about 30 seconds.

I tested 600 seconds in the 2nd option below and no difference

kapalczynski_2-1678717252013.png

 

 

NOTE: this application is not residing in AGOL or Portal its was donwloaded into our IIS and hosted from there.....

Does anyone have any ideas on what to check?

 

 

0 Kudos
1 Solution

Accepted Solutions
kapalczynski
Occasional Contributor III

I did an obnoxious Generalize on the polygons of 1000 meters and when I checked there was no more issue in the application.  It appears that although only 733 records (which span across the whole state) the geometries were to complex / too many nodes....

View solution in original post

0 Kudos
2 Replies
kapalczynski
Occasional Contributor III

I read this but again this is just 733 polygon features....The geometry renders fine in the map and is responsive but the table blows up.  If I zoom in and say 190ish records the table loads those... but even at that scale I want to see all the records and hit the button to return all the records regardless of scale and it blows up

https://support.esri.com/en/technical-article/000011736

0 Kudos
kapalczynski
Occasional Contributor III

I did an obnoxious Generalize on the polygons of 1000 meters and when I checked there was no more issue in the application.  It appears that although only 733 records (which span across the whole state) the geometries were to complex / too many nodes....

0 Kudos