Select to view content in your preferred language

After saving layer in new map viewer the feature layer renderer is not updated

645
2
Jump to solution
10-11-2023 01:33 PM
MattStayner
Occasional Contributor II

I saved a layer using the new map viewer in ArcGIS Online, and now the feature layer renderer isn't getting updated. Watch this to see the issue.

I have 2 questions:

  1. Where is the layer renderer information getting saved if not in the feature layer (I'm mostly just curious about this)?
  2. How can I take a layer that has been saved using the new map viewer and save the symbology back to the layer (this is critical for me)?

Here is the test layer I created in the video above.

Here is the codepen showing they layer loaded uses the layer renderer, not what is saved in the new map viewer.

Thanks!

1 Solution

Accepted Solutions
MattStayner
Occasional Contributor II

With some help from Esri Support, I figured out how to delete the symbology of a layer that has been saved in the new map viewer and restore it to work in the classic map viewer.

  1. Sign in to ArcGIS Online Assistant at: https://ago-assistant.esri.com
  2. Search for the feature layer and select "I want to.." >View an Item's Json
  3. Click on the edit icon (Pencil) and remove "ArcGIS API for JavaScript" line under type keyword

MattStayner_0-1698879070869.png

4. Edit the Data JSON object to be "{}".

MattStayner_1-1698879196014.png

After you do that, then, when you view the layer in the classic map viewer, or an app using ArcGIS Javascript API, then the symbology saved on the layer will appear.

View solution in original post

0 Kudos
2 Replies
MattStayner
Occasional Contributor II

Ah-ha! I found where the symbology is being saved. I watched the network traffic for the visualization tab and I see it is getting the symbology from here:

https://utilisync.maps.arcgis.com/sharing/rest/content/items/53b464e360eb4960b0b466b06e852844/data?f...

Now, the big question for me is:

How can delete that symbology and have it go back to using the drawing info renderer saved here:

https://services6.arcgis.com/ExtdhXSbhHKK7FFW/arcgis/rest/services/renderer_test_layer/FeatureServer...

0 Kudos
MattStayner
Occasional Contributor II

With some help from Esri Support, I figured out how to delete the symbology of a layer that has been saved in the new map viewer and restore it to work in the classic map viewer.

  1. Sign in to ArcGIS Online Assistant at: https://ago-assistant.esri.com
  2. Search for the feature layer and select "I want to.." >View an Item's Json
  3. Click on the edit icon (Pencil) and remove "ArcGIS API for JavaScript" line under type keyword

MattStayner_0-1698879070869.png

4. Edit the Data JSON object to be "{}".

MattStayner_1-1698879196014.png

After you do that, then, when you view the layer in the classic map viewer, or an app using ArcGIS Javascript API, then the symbology saved on the layer will appear.

0 Kudos