Zone Instant App Welcome! Won't allow a blank entry

790
5
Jump to solution
01-31-2022 02:25 PM
JenniferMcFarland-
New Contributor II

I am working on finalizing the Zone Instant App for education.  I find that the Welcome!  Message will not go away in the app.   I take it out and save and it is still there?  Is this a bug?  I was playing with the app and put the word Cats in there and it changed from Welcome to Cats.  When I deleted the word Cats Welcome came back in it’s place.   I find it a waste of space to have it there.  Is there anyway to get rid of it?  See screen shots below!  Even if I could put my logo in the place where the Welcome! is that would be great. 

  1. Welcome!

JenniferMcFarland_0-1643667865499.png

 

  1. Welcome isn’t in the settings

JenniferMcFarland_1-1643667865505.png

 

 

  1. That is where if I type Cats it will appear where the welcome is!

 

 

So my question is …  Is this a bug?   How can I make the Welcome disappear???  

 

0 Kudos
2 Solutions

Accepted Solutions
KellyHutchins
Esri Frequent Contributor

We have default text for the welcome screen so if nothing is entered we fall back to that text. I'll look into options for deleting the title via the config. In the meantime, you could turn it off by pasting the following into the custom css option in the theme section of the config panel. 

 

div.details-header{ display:none !important; } .details-content{ margin-top:0!important;}

 

View solution in original post

0 Kudos
KellyHutchins
Esri Frequent Contributor

You could add this to the custom css input. But it will affect all the buttons on the map so if you include zoom, home buttons those will be larger too. You can play around with the values in the example css below to make it look the way you want. The 48 px are the button width and height and the font-size:26px defines how big the icon is 

 

 

.esri-icon-media{font-size:26px;} .esri-widget--button{width:48px;height:48px;}

 

View solution in original post

5 Replies
BethRomero
Esri Contributor

@JenniferMcFarland- a workaround to make the "Welcome" disappear is to add an empty space in the Title for Introduction text box.  Hopefully that will help for now.  An issue has been submitted and we will look at updating this in the next update of ArcGIS Online. 

0 Kudos
JenniferMcFarland-
New Contributor II

Thanks.  That deleted the Welcome.   There is still a gap but its better than having wording that we don't want on the app.  I appreciate your help.   

0 Kudos
KellyHutchins
Esri Frequent Contributor

We have default text for the welcome screen so if nothing is entered we fall back to that text. I'll look into options for deleting the title via the config. In the meantime, you could turn it off by pasting the following into the custom css option in the theme section of the config panel. 

 

div.details-header{ display:none !important; } .details-content{ margin-top:0!important;}

 

0 Kudos
JenniferMcFarland-
New Contributor II

Thanks.  That got rid of all the white space.  Now is there anyway to make the screenshot icon larger??  lol. 

0 Kudos
KellyHutchins
Esri Frequent Contributor

You could add this to the custom css input. But it will affect all the buttons on the map so if you include zoom, home buttons those will be larger too. You can play around with the values in the example css below to make it look the way you want. The 48 px are the button width and height and the font-size:26px defines how big the icon is 

 

 

.esri-icon-media{font-size:26px;} .esri-widget--button{width:48px;height:48px;}