Print widget error

6058
5
04-23-2015 08:37 AM
AmyAxon
New Contributor II

I created an AGOL project, using Web AppBuilder ArcGIS. I used the basic print widget. However, I cannot get it to work for me. I get the following message. This project is used by several people at work and some of them do not have a problem, but some do. I have tried Chrome and Internet Explorer and I get the same error. Any idea why this is happening? I have been wondering if it has something to do with my Adobe version. I am using X Standard.  Thanks! -Amy

print_error.png

Tags (1)
0 Kudos
5 Replies
FasilTiru
Esri Contributor

Amy,

I created a sample application with web appbuilder and tested the printing functionality. I was able to get a pdf output without any problem. Please go ahead and test with my application.

ArcGIS Web Application

If you are still unable to print from this app, there must be something else that is causing the issue. You might want to install Fiddler and monitor the web traffic to see any potential errors when the print request is sent.

0 Kudos
AmyAxon
New Contributor II

Fasil:

Thank you for your response. I tried yours and it worked fine. Are you using this service: http://utility.arcgisonline.com/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%20Web%2...

I do not have my own print service, so I am trying to use that ESRI provides.

0 Kudos
FasilTiru
Esri Contributor

Amy,

I am also using the Esri Default print service (Task: Export Web Map Task ) with my application. Are you consistently getting that error message with your application in Google Chrome as well. Sometimes, if you try again it might work.

Fasil

0 Kudos
LisaHuggins
New Contributor III

I get the same error when under the advanced settings I have "Include Legend" turned on.  If I uncheck the box, I don't get the error and map outputs fine.  I need a legend so it doesn't help much.

0 Kudos
AmyAxon
New Contributor II

The problem has been resolved. I am not really sure why this worked, but I followed the below guidance provided by IT staff at work and suddenly I was able to print.

Chrome browsers at level 42 and up are affected by an update that disabled JAVA. If you are affected by this:

o In your URL bar enter chrome://flags/#enable-npapi

o Click the enable link for the Enable NPAPI configuration option

o Click the relaunch button that appears at the bottom
of the configuration page

0 Kudos