Can't add website as a main page in map journal anymore

3167
4
Jump to solution
01-04-2016 08:58 AM
KarenEdelstein
New Contributor II

I've just noticed that when I now build a new story map in the map journal template, and choose to place a website rather than a map or graphic in the main window, nothing shows up in that main window after the loading bar displays for a second. Map journals that I created several weeks ago still work fine, and if I want to add a new section with a website in a new window THERE, I can do it without any problem. Suggestions?

Thanks in advance.

Karen

0 Kudos
1 Solution

Accepted Solutions
OwenGeo
Esri Notable Contributor

Hi Karen,

I just tested this and yes, it is a mixed content issue as I suspected.

The link to your story map above points to the HTTPS version of your map journal (even though the short URL is HTTP):

https://ft.maps.arcgis.com/apps/MapJournal/?appid=278586b751454085a381b188d1cc80d0

If I access the story over HTTPS the website in the "Sane Energy Website" section does not load, but it does load if you access your story over HTTP.

http://ft.maps.arcgis.com/apps/MapJournal/?appid=278586b751454085a381b188d1cc80d0

You can usually ensure a website can be viewed in your story whether your story is accessed over HTTP or HTTPS by simply using the HTTPS form of the URL for any websites you add to your story map. However, it looks like the Sane Energy website does not support HTTPS so in this case their website will only work in your story if you access the story over HTTP.

Owen

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

0 Kudos
4 Replies
OwenGeo
Esri Notable Contributor

Hi Karen,

Sorry for the delay in responding. There is Story Maps place on GeoNet; please use that for Story Map-related questions next time.

Can you make your story map public and post or private message me a link to it so I can take a look?

Sometimes the situation you described can be due to a mixed-content issue when you mix HTTP and HTTPS content. If you are accessing your story map over HTTPS (whether or not your organizational settings require it or not) make sure you use an HTTPS URL for any web page that you add to your Map Journal. You can usually see this if you open the browser dev tools and look for mixed content errors.

Owen

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
KarenEdelstein
New Contributor II

Thanks for the reply, Owen. I did post to GeoNet, as well. Maybe it didn't go into the right space? I thought it had.

In any case, here's the link to one of the public maps I'm working on: http://arcg.is/1N7Jy99. The site that should show up is http://saneenergyproject.org/. But I've also tried to paste in http://www.google.com and http://www.esri.com. Joseph Kerski has replicated the problem when he tried it too. It happens with any new map, but I'm realizing, too, that the story map I'm linking to here was also built quite a number of weeks ago.

Hope this helps for trouble-shooting.

0 Kudos
OwenGeo
Esri Notable Contributor

Hi Karen,

I just tested this and yes, it is a mixed content issue as I suspected.

The link to your story map above points to the HTTPS version of your map journal (even though the short URL is HTTP):

https://ft.maps.arcgis.com/apps/MapJournal/?appid=278586b751454085a381b188d1cc80d0

If I access the story over HTTPS the website in the "Sane Energy Website" section does not load, but it does load if you access your story over HTTP.

http://ft.maps.arcgis.com/apps/MapJournal/?appid=278586b751454085a381b188d1cc80d0

You can usually ensure a website can be viewed in your story whether your story is accessed over HTTP or HTTPS by simply using the HTTPS form of the URL for any websites you add to your story map. However, it looks like the Sane Energy website does not support HTTPS so in this case their website will only work in your story if you access the story over HTTP.

Owen

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
KarenEdelstein
New Contributor II

Oh my gosh, that is brilliant. Thank you so much!!! How do I ensure that the link is going in as http rather than https each time?

0 Kudos