Attachment Viewer with feature layer view attachments

836
4
08-11-2021 12:11 PM
ChrisRingo
Occasional Contributor

Background: I've created a survey in Survey123 that we are using to record data for some agronomic field trials.  The survey includes photo attachments which I want to make available to the participants, and so I have configured the Attachment Viewer to accomplish this (very useful app, BTW) .

However, the photos are associated with different record types in the data model, and I would like to be able to filter by those record types so the different photo types can be viewed separately.  The Attachment Viewer doesn't have that kind of non-spatial filtering ability (unless I'm missing something), and so I've created different maps each with a different filtered view of the feature layer with the photo attachments.

Here's the problem - when I configure the Attachment Viewer to view the map with the filtered feature layer view in map-focused mode, even though the mapped points show for only the points in the filtered view (as expected), placeholders for all the photo records in the underlying feature layer show in the gallery, though only those in the filtered view actually show (see screenshot).  Clicking on one of the "placeholders" in the gallery will actually show a photo even though there's no corresponding point on the map.

Is this a known bug or am I missing a setting or something?  The attachment-focused view appears to work as expected.

Thanks!

Tags (1)
0 Kudos
4 Replies
SarahMcDonald_
New Contributor III

Hi Chris,

Thanks for reaching out about Attachment Viewer. 

For the issue that you were seeing with filtered features where attachments from all features displayed and not just the filtered features, are you still seeing this happen?

I was also curious to chat about adding filtering into Attachment Viewer, would adding the ability to filter by attributes from a feature layer in the Attachment Viewer be something that would be helpful to have when interacting with the app? 

Thanks!

Sarah 

vblack
by
New Contributor II

Hi Sarah, 

Has there been any update on being able to filter data using the Attachment viewer? I have a whole bunch of utilities being updated daily with photos and we're using the Attachment viewer app, but i'm not finding an easy solution for the end user to be able to filter by Utility unit (i.e. see only those associated with Fire, or Power only). 

0 Kudos
BrookeAumann
New Contributor III

I know this is old, but something I just had to do was copy/ paste (duplicate) the same layer and filter for the specific type to get around not having a filter widget/ option. But now my end user is saying the layers are disappearing when he gets hung up and refreshes the map, and I saw some funky behavior too. Not sure if it's a result of the layers, or something up with AGOL today.

0 Kudos
vblack
by
New Contributor II
Oh sweet yeah that's a good workaround. I'll give that a shot and hope that the filter option becomes available soon as I feel like this is an essential part of displaying data.
0 Kudos