How long until I can use insights with Enterprise 10.6.1?

2210
21
07-20-2018 09:54 PM
IsaacCabrera1
New Contributor II

I'd like to know when an Insights for Enterprise 10.6.1. will be available.  

0 Kudos
21 Replies
DerekLaw
Esri Community Moderator

Hi Isaac,

Insights for ArcGIS v3.0 will support ArcGIS Enterprise 10.6.1. It is scheduled for release in Sept timeframe.

Hope this helps,

IsaacCabrera1
New Contributor II

Any way I can get in Beta testing?

DerekLaw
Esri Community Moderator

Hi Isaac,

There is no beta planned as far as I know.

Hope this helps,

0 Kudos
SzymonPiskula1
New Contributor III

Hi Derek,

Is september still realistic? Is there anything we could do to get Insights 2.3 to work against 10.6.1 ? Like a manual edit of something or a dependency update... ?

Regards

DerekLaw
Esri Community Moderator

Hi Szymon,

> Is september still realistic?

As far as I'm aware, Insights for ArcGIS v3.0 is planned for release near the end of September.

> Is there anything we could do to get Insights 2.3 to work against 10.6.1 ? 

There are no workarounds to configure Insights for ArcGIS v2.3 to work with ArcGIS Enterprise 10.6.1. Sorry.

Hope this helps,

Joshua-Young
Occasional Contributor III

So from My Esri when I click on the reference link for Workforce it sends me over to a page that right at the top says this is which version of Workforce will work with which version of ArcGIS Enterprise. Insights just sends you to a page that says that you need Portal for ArcGIS and ArcGIS Server. You have to go hunting through the rest of the Insights help documentation to find a compatibility matrix, and unfortunately it is out of date.

Without stumbling upon this forum post I would have had no idea that Insights 2.3 is not compatible with 10.6.1. This is the only warning people get in the Portal for ArcGIS help documentation upgrade guide:

      "Ensure any Esri apps you have configured with your portal, such as Workforce for ArcGIS and Insights for ArcGIS,       are at a version that's compatible with the 10.6.1 portal before upgrading. You can upgrade any apps as needed after       upgrading the portal."

If I decide to go ahead and upgrade ArcGIS Enterprise from 10.6 to 10.6.1 right now, do I need to uninstall Insights for ArcGIS 2.3 first?

by Anonymous User
Not applicable

I upgraded a test environment from 10.6 to 10.6.1 that already had Insights 2.3 and it still works. I created a brand new 10.6.1 environment today and was surprised to find out that 2.3 can't install on it, yet it worked when I upgraded to 10.6.1 and it was already there. So to answer your question, you can go ahead and try to upgrade a test environment without touching Insights to see if it works for you like it did for me, but you'll have to wait until the end of September for the new release if you're having any problems.

Also, you're totally right, all the related documentation I can find doesn't talk about this:

Compatibility with ArcGIS Enterprise—Insights reference | ArcGIS (No column for 10.6.1)

Get started—Insights Get Started | ArcGIS ("you must have a base ArcGIS Enterprise deployment of version 10.5 or later", which is wrong)

I actually have a support case open over a minor display issue I am having with Insights, but the support analyst hasn't told me that Insights 2.3 is incompatible with 10.6.1! Not even Esri support knows, apparently! I'll have to tell him this and close the case...

Anyways, glad I found this forum post! Clearly there was no other way of knowing this. I guess I'll have to wait to give our end users 10.6.1, since they're expecting Insights!

0 Kudos
SteveLewis
Occasional Contributor

If not a beta version, perhaps a pre-release?  Thanks

Sorry, just in a tough spot when we have people waiting to use InSights again.  

0 Kudos
DianaBenedict1
New Contributor III

I just upgraded to 10.6.1 but now I am stuck with a "mostly working" install but no Insights. I could not get it to work correctly with the upgrade and no supporting install/upgrade for Insights. ESRI, you really should have documented this better and placed a disclaimer here

0 Kudos