Unable to upgrade ArcGIS Open Data Site to 2.0

6474
13
12-09-2016 03:57 PM
deleted-user-1T_bOHag6M8d
Occasional Contributor

When I attempted to upgrade my ArcGIS Open Data Site to version 2.0 nothing happens. I checked the console log and noted the error messages below.

torii-provider-arcgis.fetch called...
opendata-admin-91ef2c5….js:1 Animated Button i18n key: null for state "default"
VM480 config:1 Mixed Content: The page at 'https://opendata.arcgis.com/admin/sites/10044/config' was loaded over HTTPS, but requested an insecure image 'http://opendata.arcgis.com/favicon.ico'. This content should also be served over HTTPS.
http://opendata.arcgis.com/favicon.ico Failed to load resource: the server responded with a status of 404 (Not Found)
https://opendata.arcgis.com/api/v2/sites Failed to load resource: the server responded with a status of 400 (Bad Request)
  1. vendor-ace518b….js:8 Error: Ember Data Request POST https://opendata.arcgis.com/api/v2/sites returned a 400 Payload (application/json; charset=utf-8) [object Object] at i.t (vendor-ace518b….js:8) at i (vendor-ace518b….js:56) at n.handleResponse (vendor-ace518b….js:56) at u (vendor-ace518b….js:56) at n.c.error (vendor-ace518b….js:56) at i (jquery.min.js:2) at Object.fireWith [as rejectWith] (jquery.min.js:2) at y (jquery.min.js:4) at XMLHttpRequest.c (jquery.min.js:4)
    1. s@vendor-ace518b….js:8
      a@vendor-ace518b….js:8
      a@vendor-ace518b….js:11
      trigger@vendor-ace518b….js:15
      (anonymous function)@vendor-ace518b….js:16
      invoke@vendor-ace518b….js:3
      flush@vendor-ace518b….js:3
      flush@vendor-ace518b….js:3
      end@vendor-ace518b….js:3
      run@vendor-ace518b….js:3
      join@vendor-ace518b….js:3
      u.join@vendor-ace518b….js:9
      c.error@vendor-ace518b….js:56
      i@jquery.min.js:2
      fireWith@jquery.min.js:2
      y@jquery.min.js:4
      c@jquery.min.js:4
0 Kudos
13 Replies
CourtneyClaessens
Occasional Contributor III

Hi Nicholas - 

Thanks for reporting this issue. Can you please provide your site url and org name? 

Thank you

Courtney 

deleted-user-1T_bOHag6M8d
Occasional Contributor

Hi Courtney,

http://sjcgis.maps.arcgis.com/home/index.html 

and

http://sjcgis.opendata.arcgis.com

The org name is San Juan County GIS.

Thanks.

Nick

CourtneyClaessens
Occasional Contributor III

Hi Nicholas, 

The error is occurring because of the custom domain on your site. This is a bug and we are working on a fix, but for an immediate workaround you can temporarily remove your custom domain, upgrade the site, and add it back. 

Courtney

deleted-user-1T_bOHag6M8d
Occasional Contributor

Thanks Courtney. That worked.

0 Kudos
ShuakeWuzhati
New Contributor II

Hello,

I am having problem upgrading the site also. Changing the custom domain didn't help.

Home | CUUATS Data Portal 

and

Home | CUUATS Data Portal 

 

The org name is Champaign County GIS Consortium.

I would appreciate any suggestions. Thanks!

0 Kudos
CharlesFritz2
New Contributor III

Hi Courtney,

I also have the same problem

https://broomfield.maps.arcgis.com 

and

Home | Broomfield Open Data 

The organization name is City and County of Broomfield

Thank you,

Charles

0 Kudos
CourtneyClaessens
Occasional Contributor III

Hi Charles, 

The error is occurring because of the custom domain on your site. This is a bug and we are working on a fix, but for an immediate workaround you can temporarily remove your custom domain, upgrade the site, and add it back. 

Courtney

CharlesFritz2
New Contributor III

Thanks Courtney,

I just found this bug after sending the message on here. To re-add my custom domain will I have to re-register the CNAME with the open data domain? opendata.arcgis.com

CourtneyClaessens
Occasional Contributor III

As long as the domain is the same you do not have to re-register it. 

Courtney