Unable to apply changes to html/css editor in arcgis hub

198
2
Jump to solution
04-05-2020 12:25 PM
BrentLanford
New Contributor

I'm trying to customize the header of my ArcGIS Hub for COVID-19 by using the 'Custom HTML/CSS' option. After expanding the editor and making changes, the 'Apply' button fails to activate, leaving me unable to apply my changes. Curiously, selecting all CSS text and deleting it seems to be the only thing that activates the 'Apply' button.The problem is I don't want to delete all of the header CSS, only slightly modify it! Am I overlooking something obvious?  

0 Kudos
1 Solution

Accepted Solutions
BrianRollison
Esri Contributor

Hi Brent – the HTML/CSS editors will not allow you to apply code with errors. This is done to prevent past issues wherein custom HTML/CSS have corrupted the ability to view customer sites. If you feel the editor is erroneously throwing an error, then feel free to reach out to me directly with the code snippet at brollison@esri.com

View solution in original post

2 Replies
BrianRollison
Esri Contributor

Hi Brent – the HTML/CSS editors will not allow you to apply code with errors. This is done to prevent past issues wherein custom HTML/CSS have corrupted the ability to view customer sites. If you feel the editor is erroneously throwing an error, then feel free to reach out to me directly with the code snippet at brollison@esri.com

View solution in original post

BrentLanford
New Contributor

Thank you Brian.  I'm willing to bet that I do have an error in my CSS.  I'll re-check and correct any syntax as necessary.  Much appreciated!

0 Kudos