Strange behavior in Hub with locale settings

193
1
03-09-2022 06:37 AM
GregYoung2
New Contributor III

We are experiencing strange errors with one the items in our CarrefourGéo Ontario ArcGIS Hub site.  Any ideas on what's going on here?

Error 1

  1. The Download pane, when activated from the About view, is blank.  This only happens after searching for and navigating to the item (not if linking directly to the item) from https://geohub-fr.lio.gov.on.ca?locale=fr.  If you try it without the locale specified it works properly.

 

GregYoung2_0-1646836439616.png

 

Steps to Reproduce

  1. In Chrome or Edge browser, navigate to https://geohub-fr.lio.gov.on.ca?locale=fr
  2. Search for “points bathymétriques” and choose the first auto-suggestion that appears
  3. Click “Afficher les details complets” to open the About view
    GregYoung2_1-1646836439617.png

     

  4. Click “Télécharger” to activate the Download pane
    GregYoung2_2-1646836439618.png

Error 2

If navigating directly to the item, with “locale=fr” specified, the page freezes.  Inspection of network traffic in DevTools reveals that the application is making the same call repeatedly which seems to be locking everything up.

This is the call that the application is making in the background: https://www.arcgis.com/sharing/rest/search?f=json&q=id%3A3d4cc454239e4a52b89339205bc93751&num=1.  It just keeps repeating without any response returned:

GregYoung2_3-1646836439620.png

and eventually eats up all the memory:

GregYoung2_0-1646836953775.png

Steps to Reproduce

  1. Open a new private tab in Chrome or Edge
  2. Enable DevTools
  3. Navigate to https://geohub-fr.lio.gov.on.ca/datasets/mnrf::points-bathym%C3%A9triques/about?locale=fr
Tags (2)
0 Kudos
1 Reply
BrianRollison
Esri Contributor

@GregYoung2 thanks for posting! Please log a bug ticket with Esri Support to ensure this is resolved in the future.

0 Kudos