Receiving 404 error on data.json but can access full site

777
9
Jump to solution
02-23-2017 01:45 PM
SethLewis1
Occasional Contributor III

I've made our open data site public but am receiving a 404 error when attempting to retrieve the data.json

Our site is here http://data-tempegov.opendata.arcgis.com/  

I'm able to access the site and query each of the 34 datasets that we've shared through the Open Data group. However, appending data.json to our site's URL returns the 404.

Does anyone have any guidance as to the cause of this error?

0 Kudos
1 Solution

Accepted Solutions
CourtneyClaessens
Occasional Contributor III

Hi Seth, 

We have a fix for this and it will be released next Tuesday. 

Thanks-

Courtney

View solution in original post

0 Kudos
9 Replies
DanielFenton1
Regular Contributor

Hi Seth,

This is a known issue and we are actively working on resolving it. We’ll let you know as soon as its fixed.

Daniel Fenton

Software Engineer | ArcGIS Open Data

0 Kudos
SethLewis1
Occasional Contributor III

Thanks Daniel for the quick reply. I'll await your team's solution.

0 Kudos
SethLewis1
Occasional Contributor III

Hi  Daniel Fenton

I'm following up on this issue to see there is any kind of timetable for a fix.

Thanks!

Seth 

0 Kudos
CourtneyClaessens
Occasional Contributor III

Hi Seth, 

We have a fix for this and it will be released next Tuesday. 

Thanks-

Courtney

View solution in original post

0 Kudos
SethLewis1
Occasional Contributor III

Thanks Courtney for the update. I'll go ahead and close this question.

0 Kudos
KarenMajewicz
New Contributor II

Hi, I am still seeing this issue.  I set up a new Open Data site today that doesn't show the data.json endpoint.  I also receive 404 errors for the Tempe site mentioned above and all of Maryland iMap.  (Maybe I misunderstood the timeline on the fix; today is the following Wednesday?)

0 Kudos
SethLewis1
Occasional Contributor III

Karen -

Like you I'm still unable to access the data.json on our site (receive a 307 redirect). On other sites I'm seeing inconsistent behavior. Maryland doesn't return the data.json while the Boston and DC sites do show the JSON. I plan to stop by the Open Data booth at the DevSummit today and see if I can get more info about this issue.

0 Kudos
KarenMajewicz
New Contributor II

You are right- its a redirect, not a 404; my mistake.  It looks like sites that were recently updated are more likely to be affected.  Good luck troubleshooting it at the summit!

0 Kudos
SethLewis1
Occasional Contributor III

From talking with the Open Data team last week, it would appear that the fix to the data.json error is still being worked on and should be rolled out in the next week or two.

0 Kudos