Getting a 404 error when trying to access our open datasets pages

3376
22
Jump to solution
08-16-2016 02:04 PM
CassidyKillian
Occasional Contributor

We are trying to set up an open data beta site and we are having trouble when we click through from the categories buttons.  It comes up with a 404 Error page saying "So sorry. We looked everywhere and just can't seem to find what you were looking for."

We have configured the category buttons to work with specific groups that are all configured for public and open data access.

Any ideas what would be causing this error?  It seems like the dataset page is missing?

1 Solution

Accepted Solutions
DanielFenton1
Regular Contributor

The related data issue has now been resolved. There is still an issue with thumbnails not displaying properly. We'll get to that by next Tuesday as well.

View solution in original post

0 Kudos
22 Replies
AdrianHughes3
Occasional Contributor

We are seeing the exact same issue. Did you find a fix? We launched our portal this week and this just started happening.

0 Kudos
DanielFenton1
Regular Contributor

Hi Adrian, can you please share the link to your site? Any issue you are facing is sure to be different from the one the original poster hit 2 years ago.

0 Kudos
AdrianHughes3
Occasional Contributor
0 Kudos
DanielFenton1
Regular Contributor

I'm not seeing any 404 pages. When were you facing this issue? We just pushed a release yesterday that should have cleared up most, if not all, of the 404 errors present when using the new search beta. I do notice a missing translation on this page: https://opendata-rspb.opendata.arcgis.com/items/61f7e4ba80d34f8d9118950e62be3b9d . We'll get a fix in for that by next Tuesday's release.

0 Kudos
AdrianHughes3
Occasional Contributor

I'm seeing the issue right now in IE and Chrome.

Do you not get a 404 for the following url?

https://opendata-rspb.opendata.arcgis.com/datasets?t=Boundaries

0 Kudos
DanielFenton1
Regular Contributor

I see the issue now. You've activated the new search route which means the correct URL for you is now: https://opendata-rspb.opendata.arcgis.com/search?tags=Boundaries .

We'll get a fix in ASAP that will redirect to the correct URL and change the URLs on the category cards you have added to your home page.

Thank you for trying the beta. This feedback is extremely valuable.

0 Kudos
AdrianHughes3
Occasional Contributor

OK, I've fixed all links including links to specific datasets and our browse all data link. I have also talked with ESRI UK and they are seeing this issue across other open data sites too.

I also notice that the related data is not showing when you view a dataset ie. a list of other related datasets which I guess works through similar tags?

0 Kudos
DanielFenton1
Regular Contributor

We’ll have a fix out shortly that doesn’t rely on manually updating URLs.

The issue with related data is known and will be fixed this week barring unforeseen issues.

Related data does use tags. Not just exact matches but those that are semantically similar as well. E.g water and hydrology.

Get Outlook for iOS<https://aka.ms/o0ukef>

0 Kudos
DanielFenton1
Regular Contributor

The related data issue has now been resolved. There is still an issue with thumbnails not displaying properly. We'll get to that by next Tuesday as well.

0 Kudos