Galaxy s10e not working with Portal Apps

659
7
06-06-2019 12:02 PM
dougpare
New Contributor III

I have a Galaxy s10e running Android V9.  I am able to connect to Portal applications, but screen gestures - pan, pinch zoom do not work.  Double tap will zoom.  All other functionality is there.  The application also behaves the same on a Galaxy Note8 Android V9.  So far, all other devices (including a Tablet running V9) work fine.

I have removed the screen protector and turned up screen touch sensitivity.  No change.

The Galaxy s10e works fine with AGOL Apps and Google maps.

Anyone else experience this?  Any ideas?

Tags (1)
7 Replies
dougpare
New Contributor III

Well, no replies so far.  Does anyone have a Galaxy s10 Android ver9 that is working with portal apps?  Screen gestures work?

Thanks

0 Kudos
TylerKiehle1
New Contributor II

Did you find a solution?  We have users experiencing this same problem.

0 Kudos
GrahamHudgins
Esri Regular Contributor

which apps? native apps or browser apps? what is your browser if it's a browser app

0 Kudos
dougpare
New Contributor III

Hi Graham,

I haven’t looked into this issue in months. Anyway, it does not work with applications developed in Portal. I’m using Chrome. Works fine with things like Google Maps. Just not Portal Apps.

Doug

0 Kudos
TylerKiehle1
New Contributor II

Our issue occurs on Android 9 smartphones using the current version of the Chrome browser while using web apps hosted on Portal 10.6.1.  It works fine with Firefox browsers on Android 9.  It also works fine on Android 8 smartphones with a Chrome browser.

I found these bugs on the Esri tech support page:

https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDExOTk0MQ==

https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDExNjEwMQ==

It appears this is a known bug for the Chrome/Android 9/Portal 10.6.1 combination.  I find it mildly amusing that Esri felt this bug that prevents users with the world's leading mobile OS and browser to navigate a web map effectively in web apps hosted on their Enterprise Portal was a low severity bug.  And the solution Esri offered is, "just upgrade your Portal to 10.7 so you can utilize the next version of the ArcGIS API for JavaScript 3.27."  Uh i don't know, maybe patch the ArcGIS API for JavaScript 3.26 so we don't have to upgrade at a moments notice when your apps stop working?  I don't know about you guys, but I like to plan upgrades and avoid doing them in reaction to an emergency situation.  I guess the path of least resistance in the short term is to ask our Portal users to use Firefox while we plan an upgrade to Portal 10.7. Typical. 

BillMoody
New Contributor

Same combination except on Android 10.  Sill not working

0 Kudos
TomasPokorny
New Contributor III

Have the simmilar issue but olny with Samsung phones and web applications created via integrated WebApp Builder in Portal for ArcGIS 10.6.1. There's no problem on Samsung and WebApps created via WebApp Builder for Developers.Is there any patch for that? 10.6.1 version is still under full support, so that bug should be repaired. How can we switch into web GIS easilly with bugs like this :\

0 Kudos