Download option is disabled

644
13
02-24-2020 07:50 AM
KrishV
by
Occasional Contributor II

Hi All,

I'm using Enterprise sites 10.7.1

When I click on any of the attribute, I'm getting below error instead of Chart. Also my download option is disabled. I'm using Feature Service and Shared to everyone if I have to change anything.

Even, if there are one unique value, instead of showing some graph, it shows empty chart. Is it expected behaviour.?

Please suggest.

Thanks,

Krish

0 Kudos
13 Replies
GrahamHudgins
Esri Regular Contributor

Is this a secured service?

0 Kudos
KrishV
by
Occasional Contributor II

Hi Graham Hudgins

No, I have shared with everyone.

Thanks,

Krish

0 Kudos
GrahamHudgins
Esri Regular Contributor

Might want to move this into support to get these details. Downloading only functions for hosted feature services with extract enabled. Can you check the server version you're using?

0 Kudos
Nicole_Ueberschär
Esri Regular Contributor

You mean the Export option when I publish the layer? I am having the same problem...

0 Kudos
Nicole_Ueberschär
Esri Regular Contributor

Ok, I managed to have the download option available but the statistics are still failing to load:

(same error for all attributes)

0 Kudos
GrahamHudgins
Esri Regular Contributor

sorry yes - I believe it's the "Export" setting on the hosted service. When enabled, the server will list `extract` as a capability. 

KrishV
by
Occasional Contributor II

Hi Graham Hudgins‌,

Published a feature service without extract capability (10.6.1) to ArcGIS Server and used it in ArcGIS Hub then we were able to download the service.

Same process we followed now (tested with extract capability also). We have the download options disabled in both ArcGIS Hub and Sites.

Also, when i used 10.6.1 feature service in the sites, download status shows as shown below:

Nicole Ueberschär‌: Were you able to fix?

Thanks,

Krish

0 Kudos
Nicole_Ueberschär
Esri Regular Contributor

Hi Krish, 

Only the download is working now. Did you try a different browser yet?

0 Kudos
GrahamHudgins
Esri Regular Contributor

Thanks all for the extra details. To recap:

  • Downloads in Enterprise do not work like they do in Hub--in Enterprise we only can rely on the portal's download capabilities which are more restrictive than the download system in Online. There is an enhancement request to add this download system to Enterprise which customer support can add your name to if you'd like. It's something that is under consideration for a future release of Enterprise. The UI bug that Krish pointed out is being resolved as well in a later version of Enterprise Sites (10.8.1) 
  • For the charts, we'll investigate a 10.6.1 service against 10.7.1 Enterprise Sites and see if we can reproduce.