Data Downloads from HUB site not working

1627
14
08-28-2020 08:17 AM
Alyssia
Occasional Contributor

I just built my first HUB site to make it easier to share data with outside entities. However, I have a big issue. When I go to download certain layers (such as our city limits or ETJ polygons), only certain file types will download successfully. In general, the file geodatabase type and spreadsheet data will download just fine, but if I try to download as a shapefile or KML, the download button just shows that it is downloading forever...it "hangs". 

I haven't tested every layer, but it seems that some work fine (like our City Council Districts), and some do not .

Here is the link to the site if you want to try it out yourself: Cibolo GIS Open Data 

Any tips?

Tags (2)
0 Kudos
14 Replies
Alyssia
Occasional Contributor

Update: I got some of the layers to work by disabling their M and Z values (not needed in the layers, but were carried over from old CAD files). 

Some layers are still being very slow to download to KML format. 

0 Kudos
ThomasHervey1
Esri Contributor

Hi Alyssia, do you have a particular dataset that is giving you troubles that I could look into? We are just about to release a new UI that will alert users to the status of download files as well as if there is a fresher version that needs time to create. This can often be the reason you see a 'hanging' download since on our end a new file is being created.

Thanks,

Thomas

Alyssia
Occasional Contributor

Yes, right now it seems that the KML format of the Zoning layer is hanging. I waited 20 min the other day and it never downloaded. https://cibologis-cibolotx.hub.arcgis.com/datasets/city-of-cibolo-zoning?geometry=-99.515%2C29.353%2...

0 Kudos
ThomasHervey1
Esri Contributor

Thanks for the link. This looks like a file creation bug that we will look into. Have you had an issue with KML downloads for items that are published initially without a M or Z value?

0 Kudos
Alyssia
Occasional Contributor

I have had issues with many files, both with and without Z and M values enabled. When I first posted my issue here, I was having issues with 3 of my 10 files on Hub - City Limits, ETJ, and Zoning.

Only City Limits and ETJ had M and Z values enabled. When I disabled them, and re-uploaded, they started working as expected about an hour later.

The City Limits layer initially would only work well for Spreadsheet and FGDB, the KML took at least 10 min, and the Shapefile took 25-30 min to download. 

The ETJ layer initially would only work for FGDB, no other formats worked. 

My zoning layer is the only one right now that refuses to download the KML format. It is not M or Z enabled, and is less "complicated" then many of my other layers that work fine. 

0 Kudos
ThomasHervey1
Esri Contributor

Thanks for the update. I have filed a bug for your KML issue and an engineer is looking into it right now. Regarding long download times, this can be expected because new files need to be created once an update is made. Unfortunately the UI is a bit misleading because before a download can complete, a file needs to be created, which can take a long time in some cases. Be on the lookout for the new download UI within a week or so. It'll be a beta setting under site settings and there will be a blog post reviewing the changes. Also, next time you run into an issue with one of the other datasets, please let me know.

Thanks,

Thomas

0 Kudos
NishantSrivastava
New Contributor

I'm having similar issues with dataset here: 116th Congressional Districts 

In the 'Data' tab, the loading of the datatable is erratic, correctly loading about 1 out of every 4 times I refresh. Have been trying since yesterday to download any of the options to no avail, just been seeing an animated arrow on the Downloads button.

Appreciate your insight into why this is happening, but any idea on when it could be remedied?

0 Kudos
ThomasHervey1
Esri Contributor

Thanks for the link Nishant, we'll look into why the dataset table is not loading. This item is a Map Image Layer which can sometimes take a while to generate a download file, also sometimes there are issues with downloads from non-hosted services. Are you the owner of this item?

0 Kudos
NishantSrivastava
New Contributor

Hi Thomas, no I'm not the owner of the item. I discovered it yesterday, and left it overnight to attempt to download thinking the same, that a server issue or GET issue was to blame, but it didn't work. Should I reach out to the owners about the issue?

0 Kudos