Crowdsource Polling App - inconsistent behavior/access in a Hub Site depending on card type used to access

337
1
Jump to solution
05-05-2022 06:29 PM
cassklee
New Contributor II

Hi there.  Want to share existing crowdsource polling apps within my Hub and am experiencing inconsistent behavior depending on how the app is exposed:

Application Card with Classic Story Map:  OK

cassklee_0-1651799904925.png

App shared as a link within Text Card and opening in a new browser tab:  OK

cassklee_1-1651799991623.png

App shared using an App or Iframe Card:  NOT OK

App shared using a Gallery Card:  NOT OK

Our preference is to use a Gallery Card or an App Card to share the apps:

cassklee_3-1651800127724.png

Therefore, it would be helpful to understand why in these "use cases" receive the following...

You are currently signed in as: 'xxx'. You do not have access to this resource: public proxy layer

Thank you!

PS:  Understand that the url above is referencing the public/proxy layer as described in the article below...

https://support.esri.com/en/technical-article/000017029

Public/proxy layer is shared with Everyone and as noted does not cause a problem in the first two "use case" scenarios.

0 Kudos
1 Solution

Accepted Solutions
cassklee
New Contributor II

Discovered the remedy.  Needed to access the Hub site anonymously.  Once the Hub site was shared with 'Everyone' was able to access the polling app using a public proxy layer via an app card or gallery card. 

View solution in original post

0 Kudos
1 Reply
cassklee
New Contributor II

Discovered the remedy.  Needed to access the Hub site anonymously.  Once the Hub site was shared with 'Everyone' was able to access the polling app using a public proxy layer via an app card or gallery card. 

0 Kudos