Address Locators in a gedodatabase 10.6.1 issue

555
6
Jump to solution
04-05-2019 12:18 PM
TimWitt2
MVP Regular Contributor

Hey everybody,

I just migrated from 10.3.1 to 10.6.1 and now when I open one of the geodatabases that has my address locators in it, I don't see them anymore. Is this a know issue?

To update one of my other programs that uses those address locators,I need to be able to rebuild those locators (they are 10.1 locators).

Any input is appreciated!

Thanks,

Tim

0 Kudos
1 Solution

Accepted Solutions
MichaelVolz
Esteemed Contributor
6 Replies
MichaelVolz
Esteemed Contributor
JoeBorgione
MVP Esteemed Contributor

Tim- I think after about 10.3.1 ESRI forces your hand not to store locators as a geodatabase object.  At one time I did the same thing, so my locators, in data, match to data, and out data, were all in the same container.  It seems to me I went away from that practice before 10.x, as it was not considered best practice.  From the help docs :

Locators should be stored in a file folder so you take advantage of new features that are not supported for locators stored in geodatabases, such as performance improvements, multithreading capabilities, and suggestions support. ArcGIS 10.4 is the last release to support storing locators in geodatabases.

That should just about do it....
TimWitt2
MVP Regular Contributor

I would totally do that, if it wasnt for our 911 mapping software to require it being in a gdb  

0 Kudos
MichaelVolz
Esteemed Contributor

Sounds like a show-stopper until you can upgrade your 911 mapping software that does not require address locators stored in a gdb.

JoeBorgione
MVP Esteemed Contributor

Always a problem with 3rd party apps.  When I was dispatching I had the same sorts of issues.  Are you going back to the earlier version?

Tim Witt

That should just about do it....
0 Kudos
TimWitt2
MVP Regular Contributor

I might set up a 2nd PC with 10.3.1 just to create my updates.

0 Kudos