GeoEvent working but no new points

349
3
Jump to solution
05-27-2021 02:51 PM
VanessaSimps
New Contributor III

I have been asked to create a GeoEvent that will pull in new csv files and add them to an existing point file. The point feature class is on our Entertpirse database and published as a feature server from our ArcServer (so not hosted on ArcGIS Online). I want to be able to show this layer in a web map/app and have new points added when they come in. 

I have the following set up:

IN: Watch a Folder for New CSV Files

PROCESSOR: Field Mapper

OUT: Add a Feature

VanessaSimps_0-1622151925468.png

I can see that the new files are being processed and the little map viewer shows the point on the map. However, this new point doesn't show up in the database/feature layer. I am not getting any log errors, and it appears to be working from inside the GeoEvent interface. I feel like I am SO close, but am missing some little detail. 

Thanks in advance!

Vanessa-

0 Kudos
1 Solution

Accepted Solutions
VanessaSimps
New Contributor III

Hi - thanks for the response. It turned out that this had to do with the fields not all lining up in the field mapping step. I have since gotten that part all figured out and am successfully seeing the feed of points as expected. 

View solution in original post

3 Replies
JonEmch
Esri Regular Contributor

Hello Vanessa, thank you for posting.

   Can you comment on the version of GeoEvent you are using? If it's 10.8 and newer, you should be able to "intercept" the geoevent as it goes through the process to see where exactly the hang up is. Also, take a look at the data sets attribute table to see if the data is getting added, but maybe not the geography?

Looking forward to your reply!

Keep on keeping on!
0 Kudos
VanessaSimps
New Contributor III

Hi - thanks for the response. It turned out that this had to do with the fields not all lining up in the field mapping step. I have since gotten that part all figured out and am successfully seeing the feed of points as expected. 

View solution in original post

JonEmch
Esri Regular Contributor

Excellent, thank you for the follow up Vanessa!

Keep on keeping on!
0 Kudos