Geoevent Manager stopped working - 10.2.2

3444
1
03-05-2015 02:26 PM
Highlighted
Occasional Contributor

All of sudden my GEP manager (10.2.2) website stopped working.  It shows HTTP 502 error when I access.

Log file shows below error message. Services are running fine, but I could not get manager up. Any clues?

INFO   | jvm 1    | 2015/03/05 16:18:23 |at java.lang.Thread.run(Unknown Source)

INFO   | jvm 1    | 2015/03/05 16:18:23 | ERROR: Bundle com.esri.ges.rest.cxf-transportrest [342] Error starting mvn:com.esri.ges.rest/cxf-transportrest/10.2.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle com.esri.ges.rest.cxf-transportrest [342]: Unable to resolve 342.0: missing requirement [342.0] package; (&(package=com.esri.ges.jaxb.transport)(version>=10.2.0)(!(version>=11.0.0))) [caused by: Unable to resolve 292.0: missing requirement [292.0] package; (&(package=com.esri.ges.core)(version>=10.2.0)(!(version>=11.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (package=javax.crypto)]])

INFO   | jvm 1    | 2015/03/05 16:18:23 | org.osgi.framework.BundleException: Unresolved constraint in bundle com.esri.ges.rest.cxf-transportrest [342]: Unable to resolve 342.0: missing requirement [342.0] package; (&(package=com.esri.ges.jaxb.transport)(version>=10.2.0)(!(version>=11.0.0))) [caused by: Unable to resolve 292.0: missing requirement [292.0] package; (&(package=com.esri.ges.core)(version>=10.2.0)(!(version>=11.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (package=javax.crypto)]]

INFO   | jvm 1    | 2015/03/05 16:18:23 |at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
INFO   | jvm 1    | 2015/03/05 16:18:23 |at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
INFO   | jvm 1    | 2015/03/05 16:18:23 |at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
INFO   | jvm 1    | 2015/03/05 16:18:23 |at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
Tags (1)
1 Reply
Highlighted
Occasional Contributor

I had a similar issue and after spending a few hours on the phone w/ tech support just ended up upgrading to 10.3 and it works fine. I tried uninstalling / re-installing several times. Also uninstalled, manually renamed the old directory in program, and re-installed.

10.3 seems to be running much better for me. 

Hopefully someone shows up with a better suggestion good luck!

Reply
0 Kudos