Deleting a path line in a Service (10.2.1)

1558
2
01-17-2014 06:41 AM
Regular Contributor
I have opened up a GEP Service to edit it in IE9 and Chrome.

The screen remains blank and locks up in IE9.

Everything works in Chrome, but I am not able to delete a connector line between inputs, processors, filters and outputs.  For example, I want to insert another processor in the middle of the Service between two others I wish to keep.  How do I eliminate the original line?

I also miss being able to copy and paste processors (or even just equations or lists) from one service to another and just selecting a tab to get back and forth between services.  Is the old Service Designer still compatible?

Thanks,
--Adam
Reply
0 Kudos
2 Replies
Esri Regular Contributor
Hey Adam -


I have opened up a GEP Service to edit it in IE9 and Chrome. The screen remains blank and locks up in IE9. Everything works in Chrome...
If you'd like, I can take a look at the GeoEvent Service's layout and properties if you export the XML configuration and send it to me. You're observing this using the 10.2.1 release? Have you tried clearing the IE browser cache, logging-out and back into Manager? There was a security feature added to 10.2.1 which automatically logs you out after 1 hour. The time is configurable from within a product config file if the log-out is getting in your way. I've sometimes seen odd behavior when my session has expired and I try to do something like open a GeoEvent Service for editing.


I am not able to delete a connector line between inputs, processors, filters and outputs. For example, I want to insert another processor in the middle of the Service between two others I wish to keep. How do I eliminate the original line?
We can look at adjusting the pixel tolerance if it's proving difficult to select a connector line. You should be able to click the line (it will highlight/glow when selected) and press 'Delete'.


I also miss being able to copy and paste processors (or even just equations or lists) from one service to another and just selecting a tab to get back and forth between services.
We will look into being supporting copy/paste of user entries from the different properties panels. I think the feature was added to the 10.2.2 release (due out March / April) to copy service elements such as processors and filters within a service, but you still won't be able to copy them from one service to another. As far as working with tabs ... can  you try using the Browser's tabs, effectively opening a new window, and working on the two services you want to edit that way? Please let me know if that works for you.

Thanks -
RJ
Reply
0 Kudos
Regular Contributor
Hey Adam -

If you'd like, I can take a look at the GeoEvent Service's layout and properties if you export the XML configuration and send it to me. You're observing this using the 10.2.1 release? Have you tried clearing the IE browser cache, logging-out and back into Manager? There was a security feature added to 10.2.1 which automatically logs you out after 1 hour. The time is configurable from within a product config file if the log-out is getting in your way. I've sometimes seen odd behavior when my session has expired and I try to do something like open a GeoEvent Service for editing.


Thanks RJ.  We can do that.  I have tried those things and done so within an hour.

We can look at adjusting the pixel tolerance if it's proving difficult to select a connector line. You should be able to click the line (it will highlight/glow when selected) and press 'Delete'.


Doh!  :eek: I was looking for a drop-down selection from a right mouse click.  I can select, but never thought to use the 'Delete' key....  Embarrassing!

We will look into being supporting copy/paste of user entries from the different properties panels. I think the feature was added to the 10.2.2 release (due out March / April) to copy service elements such as processors and filters within a service, but you still won't be able to copy them from one service to another. As far as working with tabs ... can  you try using the Browser's tabs, effectively opening a new window, and working on the two services you want to edit that way? Please let me know if that works for you.


That would work for me.  At least I could copy strings of text from within an element and paste to the other.  I remember trying to do that with field names in a previous release, but sometimes the older of the two windows closed on me after a few minutes.  I think that was what happened.

Regardless, thank you for your help once again, RJ!
--Adam
Reply
0 Kudos