Cannot connect to my server in SErvice designer

2704
5
10-15-2013 05:02 AM
MiriEshel
New Contributor III
Hi everybody,

I've installed ArcGIS GeoEvent Processor and the installation went smooth. I have a license and I authorized the software.

I have no problem to enter the manager with https://localhost:6143/geoevent/manager/index.html but when I try to connect to my server in Service Designer, where I entered the default username (arcgis), the default password (manager), I get the attached error message.
I attach also the Karaf.log. It shows "License status: GeoEventProcessor: licenseStatusSuccess" but after that, there are errors so maybe this is the problem.

What do I do wrong?

Thanks a lot,
Miri
Reply
0 Kudos
5 Replies
by Anonymous User
Not applicable
Original User: RJ Sunderman

Hello Miri -

I do not believe that the errors you are seeing in the karaf.log are coupled with the pop-up "You do not have a trusted certificate ..." you are seeing. I've verified that launching the Service Designer and attempting to authenticate with the default username and password ('arcgis' / 'manager') do not generate any messages in the karaf.log ...

Have you used Internet Explorer to add the JKS certificate generated by GEP to a local store of trusted certificates? When installing GEP for the first time - or when deleting the geoEventSSLCertificate.jks from the C:\ProgramData\Esri\GeoEventProcessor\certs folder and allowing GEP to generate a new one - you need to use IE to include the certificate as trusted. If you don't you will not be able to launch the Service Designer and successfully connect to the server.

The section "Marking GeoEvent Processor�??s self-signed certificate as trusted by Internet Explorer" in the IntroductionToGeoEventProcessor.pdf walks through how to do this. You can download the tutorial from the GEP" rel="nofollow" target="_blank">http://www.arcgis.com/home/group.html?owner=GeoEventTeam&title=A... Product Gallery. I've seen this page take several seconds to display; please make sure that the 'Show ArcGIS Desktop Content' checkbox is checked and refresh the page if you do not see the Intro tutorial listed.
Reply
0 Kudos
MiriEshel
New Contributor III
Hi RJ,

Thank you for yor reply.

I worked exactly according to the section "Marking the self-signed ArcGIS GeoEvent Processor for Server certificate as trusted by Internet Explorer" and that's how I see the manager.
It is still strange that I'm able to enter to the manager (after clicking "Continue to this website") but not the Service Designer.
Anyway, I will try deleting the geoEventSSLCertificate.jks file and see what happens.
I always work with IE (IE8).
I'll keep you posted.

Thanks a lot,
Miri
Reply
0 Kudos
by Anonymous User
Not applicable
Original User: RJ Sunderman

Miri - A couple of thoughts:

1) If you still need to click 'Continue to this website' then you don't have a trusted certificate. You need to be able to browse to https://localhost:6143/geoevent/manager "in the clear" without any security warnings. Otherwise the .NET implementation of Service Designer will not be able to obtain a trusted connection to the server and will not connect.

2) If you do delete the geoEventSSLCertificate.jks file, make sure that you stop and restart the ArcGISGeoEventProcessor service from Windows Services. The JKS file will not regenerate unless the service fails to find the file when starting.

3) There are some known limitations with IE8 such as the inability to register folders as Data Stores with GEP Manager. We'd recommend upgrading to at least IE9 or using a Latest Chrome or Firefox browser.

The 10.2.1 release of GeoEvent Processor due out this winter will retire the .NET Service Designer application and replace it with the ability to create and edit GeoEvent Services within the GEP Manager. Hopefully this will alleviate some of the frustration with needing to work with "trusted" certificates.

- RJ
Reply
0 Kudos
MiriEshel
New Contributor III
Hi RJ,

I did not have to delete geoEventSSLCertificate.jks file.
As you wrote " If you still need to click 'Continue to this website' then you don't have a trusted certificate.", I clicked on the red X, View Certificate, Install certificate, select Trusted Root Certification Authorities and the import succeeded.
Then the connection in Service Designer succeeded.

I hate these certification issues, specially the self-signed certificate.....

Thanks a lot,
Miri
Reply
0 Kudos
by Anonymous User
Not applicable
Original User: BeijingA02040

dear Miri,

    I met the same question like you, and I deal with it by your method.Then the connection in Service Designer succeeded.That is cool!

    Thanks a lot!

Hi RJ,

I did not have to delete geoEventSSLCertificate.jks file. As you wrote " If you still need to click 'Continue to this website' then you don't have a trusted certificate.", I clicked on the red X, View Certificate, Install certificate, select Trusted Root Certification Authorities and the import succeeded.
Then the connection in Service Designer succeeded.

I hate these certification issues, specially the self-signed certificate.....

Thanks a lot,
Miri
Reply
0 Kudos