webapp proxy configuration

4291
2
02-08-2016 02:52 AM

Dear community,

I have implemented a webApp with webappbuilder for developer that use a map from an arcGis server that not have a public IP. I have downloaded the app and published it on my company web server. I have also a portal installation and a web adaptor configured on both.

Obviously this doesn't work; there are several calls to private arcGis server url http://192.168.xx.xx/arcgis/..... that not are resolved.

How can I fix this?

The only solution is add a proxy rule on web server for arcgis path so when I add layer on map builded from portal, I use http//public address/arcgis/...  rather than http://192.168.xx.xx/arcgis/...   ?http://192.168.xx.xx/arcgis/

Thanks a lot.

Reply
0 Kudos
2 Replies
MVP Esteemed Contributor

tagging Web AppBuilder for ArcGIS​    Portal for ArcGIS​   ArcGIS for Server​  Web AppBuilder Custom Widgets

so your question will get more exposure (and hopefully more answers)

EDIT: btw, I added a section in Web AppBuilder Developer Edition - Customization Resource List   with several security and proxy links.

EDIT: have you tried using your machine name instead of the IP?

Also, if you have Portal installed, you may want to us that as your AppID and/or where you develop the webappbuilder app, so it works isolated there instead of needing access to AGOL.

Some specific links that may help:

Setting up a Proxy | Support Services Blog

Internal ONLY Web Map Sharing Issues

Thanks for the post.

My problem is this: the arcGis server isn't public so, also if I use the machine name, this isn't resolved from a DNS.

When in Portal for arcGis I create a new map I have to put the address of arcGis server, and this is a private address.

portal.png

Also in WAB, if I have to configure the query widget, I have to put as a data source the private address of arcGis server.

Internally is all ok. When I publish the package builded with WAB on my Apache web server to use the app from Internet and I light on a layer, in the browser I see this call (same behaviour on activate query widget ...):

http://<arcGisServerPrivateAddress>/arcgis/rest/services/<ServiceName>/MapServer/export?dpi=96&transparent=true&format=png32&layers=show%3A0%2C3%2C1&bbox=......

Obviously this doesn't work on Internet. How can you get around this?

Thanks a lot.

Reply
0 Kudos