Select to view content in your preferred language

Fetch Updates Error - Cannot read property 'headers' of undefined

2075
15
11-17-2022 09:42 AM
GIS_Admin
New Contributor II

I am testing a workflow where I use the "When a record is deleted from a feature layer" trigger and then use the "Fetch updates, changes, or deletions from feature layer" action and receive the error: "Cannot read property 'headers' of undefined" when the Fetch action runs. 

Layer is a hosted feature layer in ArcGIS Online and has the requisite track changes settings.

 

 

15 Replies
SeanKMcGinnis
Esri Contributor

@KevinMantels & @GIS_Admin,

I just tested it with a create and update triggers and was not able to recreate the error you are encountering. Could you share a screen shot or an export of the flow you are having the issue with?

Screen Shot 2022-12-02 at 7.34.41 AM.png

 

Screen Shot 2022-12-02 at 7.35.35 AM.png

 

-sean
Sean McGinnis - ArcGIS for Microsoft 365 Product Manager
0 Kudos
GIS_Admin
New Contributor II

@SeanKMcGinnis I attached screen shots as a part of this original post. Do you need something else?

0 Kudos
SeanKMcGinnis
Esri Contributor

@GIS_Admin & @KevinMantels - my suggestion would be to submit a support ticket so they can help identify the source of the issue. When those tickets are created, could you email me at smcginnis@esri.com so I can follow along to help them and try and understand the source of the issue?

-sean
Sean McGinnis - ArcGIS for Microsoft 365 Product Manager
0 Kudos
KevinMantels
New Contributor II

@SeanKMcGinnis, thanks for the suggestion and sorry for the delayed response.  Is there a particular place I should submit a ticket?  I went to the "Request Case" page and reviewed most of the product category and subcategory options but there doesn't appear to be an option for Power Automate.  I just want to make sure I submit my ticket to the right place.

Request Case OptionsRequest Case Options

 

0 Kudos
SeanKMcGinnis
Esri Contributor

@KevinMantels - interesting that it is not there. Log it with Power BI, it is the same team that supports Power Automate.

-sean
Sean McGinnis - ArcGIS for Microsoft 365 Product Manager
0 Kudos
sxw_eaglegis
Esri Contributor

I have seen this issue occur before and disabling and then re-enabling editing on the hosted feature layer resolved the issue. 

Haven't quite worked out why the issue occurs though.