5.0 Excel Map won't Import Any Excel Data

560
10
Jump to solution
02-14-2019 11:21 AM
Highlighted
New Contributor

Downloaded the new 5.0 update.  I can't get any excel records into the map.  I keep getting "An error occurred while processing this action.  Please try again." when I select excel data from the map window.   I can add layers from portal.  Is anyone experiencing a similar issue? 

1 Solution

Accepted Solutions
Highlighted
New Contributor

We solved the problem:   Arc for office users need to have publisher privileges (we ended up make a custom role for our org).    

View solution in original post

10 Replies
Highlighted
Occasional Contributor

Good Afternoon Kevin...Thank you for your post here! I have a few questions to hopefully help guide us towards a resolution. Please see my questions below:

  1. What type of data are we working within your excel sheet (addresses, xy coordinates, etc)?
  2. Is the error specific to a worksheet or opening up any worksheets (with existing or blank)?
  3. Have you uninstalled and tried reinstalling Map for Office extension (perhaps this was a 'bad' install)?

Let me know your thoughts or findings. 

Best, 

Shannon | Product Engineer

Reply
0 Kudos
Highlighted
New Contributor III

Hi Shannon,

I'm having a very similar issue. I downloaded the Map for Office extension just today (ArcGISMapsForOffice_x64_5.0.1_en.exe). When I open Excel I see the ARCGIS MAPS tab, I can sign in successfully, but when I go to "Add Map" it refuses to load data from excel - it just hangs loading and loading and loading. I can add data from the ArcGIS data tab without any problem. I am signed into an account with an Admin role and permission to publish. I've got x,y coordinates not addresses. I've tried opening from several different excel files (both with existing coordinates and blank).

Any suggestions?

Reply
0 Kudos
Highlighted
Occasional Contributor

Good Morning Alicia, 

Are you experiencing this issue currently? Could you also confirm you are using version 5.0.1and perhaps, upload a sample of your data here?

All the best, 

Shannon | Product Engineer

Reply
0 Kudos
Highlighted
New Contributor III

Hi Shannon, 

I'm still experiencing the same problem. I do in fact have version 5.0.1. 

Highlighted
Frequent Contributor

I was able to display coordinates just yesterday, about 4500 records, and I have version 5.0.1 too, so it's not failing for everyone. I notice your coordinates have a LOT of decimal places.  I wonder if its getting hung up on those?  Have you tried creating a variation of your columns that has fewer?

Highlighted
New Contributor III

I've tried no trailing zeros and without decimal altogether. I've also tried changing the field format from numeric to general and to text. No luck yet.

Reply
0 Kudos
Highlighted
Frequent Contributor

Has this worked for you in past versions?  For me, I had to try 3-4 different map projections before I happened on the right one.  The source of the data I was using didn't give enough details for what their coordinates were in, they just said NAD 83, State Plane.   That's still a long list for every state and I had to try a few before it worked.  Before then, my points were in Michigan instead of Missouri.  

Reply
0 Kudos
Highlighted
Occasional Contributor

Thanks Alicia, @Tracy had a great suggestion to start eliminating possible causes. Also, is this xy data the orginal worksheet or did you use the tool to add xy coordinates from Maps for Office? 

One more suggestion, check the coordinate system being used. I had this happen to me before and it was because I was using the wrong projection. 

Here is the link for our online documentation, it maybe useful - https://doc.arcgis.com/en/maps-for-office/design-and-use/add-coordinates.htm

Best, 

SC

Reply
0 Kudos
Highlighted
New Contributor

We solved the problem:   Arc for office users need to have publisher privileges (we ended up make a custom role for our org).    

View solution in original post