Relationship field values not showing in Field Maps popup

402
2
Jump to solution
04-11-2023 07:44 AM
TanGnar
Occasional Contributor

I'm using Enterprise 10.9.1. I configure my popup in Map View (new). I am able to add a Field List to the popup configuration and include fields from a 1:1 relationship. The values appear fine in the popup in the Map Viewer. 

However, in Field Maps, the fields in that part of the popup are blank. 

Is this known or expected? Is there a way to make this work in FieldMaps? 

1 Solution

Accepted Solutions
TanGnar
Occasional Contributor

I see, it's a bummer to have to sacrifice the benefits of the new map viewer popup configuration. 

I did find a workaround that surprisingly works, though it's a bit of a pain in the neck with a lot of fields. I can use arcade to get the related record and return a field value, and I can choose to display THAT in the Fields List configuration. And it displays in FieldMaps. My field users can see what I need them to see in the popup, even if the configuration is a bit ugly. 

Edit: accepted my response as Solution just so people can see the work around, but thanks for the info. 

View solution in original post

2 Replies
DougBrowning
MVP Esteemed Contributor

Related tables are only supported in hosted layers for now in the new map viewer.  Has been a major bummer for us also.  It has been years now but I still cannot get them to give me a date at all.  Relates really only work in the old map viewer.  Which is super weird since the world runs on RDBMS.  When they do get added you will have to update to the latest server also I think.

0 Kudos
TanGnar
Occasional Contributor

I see, it's a bummer to have to sacrifice the benefits of the new map viewer popup configuration. 

I did find a workaround that surprisingly works, though it's a bit of a pain in the neck with a lot of fields. I can use arcade to get the related record and return a field value, and I can choose to display THAT in the Fields List configuration. And it displays in FieldMaps. My field users can see what I need them to see in the popup, even if the configuration is a bit ugly. 

Edit: accepted my response as Solution just so people can see the work around, but thanks for the info.