Related table edit fields not showing

401
3
10-20-2021 08:49 AM
Jg3197
by
New Contributor II

Hi all,

I've just created a feature layer (infrastructure) and related table (inspections) to use with ArcGIS apps. I used Map viewer classic in ArcGIS Online to do this as I don't think it's yet possible in the new map viewer. I have created an online and an offline version of the map for my team.

In Field Maps on Android, I am able to view the associated records for a given feature successfully, however when I try to add a new inspection to the related table on an offline map, the form which comes up is blank - the fields I need to populate are missing, so I can't actually add any information anywhere. It seems to be fine with the online version. If I open the same map up in Collector and try to make an inspection, the form comes up correctly with the offline maps and I am able to populate the fields and submit new records successfully, which makes me think there is perhaps a bug?

Thanks,

Jen

3 Replies
BradMead
New Contributor III

Hi Jen,

We too are encountering the same issue with a related table with attachments enabled. We are able to attach photos, but the fields are not editable.

Sorry this isn't helpful, 

-Brad

 

DougSims_GT
New Contributor III

I am having the same issue. However, I have the same layer (and same related table) in a different web map and everything is correctly editable in Field Maps and in Collector. 

Just the one web map is not working for adding related records in Field Maps (it does work for that same map in Collector though). 

The biggest difference between the 2 web maps in my case is that the one that doesn't work in Field Maps has Offline Areas defined. The online only map works correctly in Field Maps. (again, same hosted feature layers and related tables in both instances)

0 Kudos
Jg3197
by
New Contributor II

So, my issue was solved - I actually just waited 24 hours and it magically resolved itself.

I've used AGOL apps quite a bit since I posted that message and have found that this happens quite often. If something which should work doesn't, either just waiting a day and trying again, or sometimes making a copy of a map, seems to resolve most of my issues. It's not ideal though, especially if you're in a hurry to get something done!

0 Kudos