Select to view content in your preferred language

Images from url not displaying in Popups

812
3
07-07-2023 02:35 PM
Smithor
New Contributor

Hello,

I am encountering an issue where any images I have set to display at the top of my popups are not displaying on either Fieldmaps (Where we are looking to mainly deploy this solution) or ArcGIS online. The images are internet hosted and publicly accessible (s509686962.online-home.ca/Signs/W_NoExit.svg). I can tell that they are accessible to the devices themselves, because if I click the "Image failed to load" in order to check the url of the image, it displays fine on the browser.

As far as I can tell, it isn't a strictly type issue, I also tested with .png (s509686962.online-home.ca/Signs/W_NoExit.png), and that also failed to load on ArcGIS online, although it did work on Fieldmaps. I would rather use SVGs if possible, and I did expect it to load in Fieldmaps if it loaded in ArcGIS Pro. While the main user using it will be doing it from the app while in the field, there are other users who will be using the webmap in the browser, and so the solution is not complete without full parity.

If for some reason this is somehow an error on my part, I would love to know, or if it is a genuine bug let me know where to properly place it so that it can be rectified. I've also included screenshots below to show the state of each (ArcGIS Pro, ArcGIS Online, and Field Maps respectively).

 

Thank you,

Screenshot 2023-07-07 153123.pngScreenshot 2023-07-07 153105.pngScreenshot_20230707_152235_Field Maps.jpg

 

 

0 Kudos
3 Replies
RhettZufelt
MVP Notable Contributor

Not sure, but could be because AGOL requires https now, not http.  I see your images server is only sending http.

R_

KathleenCSki
New Contributor III

Maybe the image format type. From the portal help file, I do not see SVG supported as an online format type.

Supported attachment formats

The following file formats are supported as attachments:

7Z, AIF, AVI, BMP, CSV, DOC, DOCX, DOT, ECW, EMF, EPS, GEOJSON, GIF, GML, GTAR, GZ, IMG, J2K, JP2, JPC, JPE, JPEG, JPF, JPG, JSON, M4A, MDB, MID, MOV, MP2, MP3, MP4, MPA, MPE, MPEG, MPG, MPV2, PDF, PNG, PPT, PPTX, PS, PSD, QT, RA, RAM, RAW, RMI, SID, TAR, TGZ, TIF, TIFF, TXT, VRML, WAV, WMA, WMF, WMV, WPS, XLS, XLSX, XLT, XML, and ZIP.

Smithor
New Contributor

Thanks for the responses guys,

I suspect it could be a little of both. I did read a bit about there being a requirement for https being required for some things, but didn't realize it applied to this case. That would explain why the png files load on Fieldmaps and ArcGIS Pro, but not for AGOL. I am genuinely surprised that neither fieldmaps nor AGOL support SVG files, I would have thought that if Pro did, then they all did, since it feels like Pro's whole job is just to prepare data for AGOL.

 

In any case, thank you two for your comments. Hopefully they improve this facet in the future.

0 Kudos