Field Maps not honoring symbology on Location Sharing layer

883
7
Jump to solution
03-01-2023 07:06 AM
AshleyPeters
Occasional Contributor III

We have recently started using Location Sharing (formerly Tracker). In the map viewer on AGOL, each user's initials show on the symbol for last known location. This holds true on Track Viewer as well. However, in Field Maps (app version 23.1.0 build 984), each user shows the default 'AF' in the last known location symbology. This is occurring on iPhones, not sure about Androids. Anyone else encountered this? Is this a bug?

0 Kudos
1 Solution

Accepted Solutions
JustinColville
Esri Contributor

Hello Ashley,

Unfortunately this is a known issues in Field Maps on both iOS and Android and the Maps SDKs (formerly Runtime).  The symbol type used by default when the Tracks layers are added to a map in Map Viewer is not supported correctly at this time.

Changing the symbol and using labeling would be one option to accomplish something similar now.

 

View solution in original post

0 Kudos
7 Replies
JustinColville
Esri Contributor

Hello Ashley,

Unfortunately this is a known issues in Field Maps on both iOS and Android and the Maps SDKs (formerly Runtime).  The symbol type used by default when the Tracks layers are added to a map in Map Viewer is not supported correctly at this time.

Changing the symbol and using labeling would be one option to accomplish something similar now.

 

0 Kudos
LearnThenShare
New Contributor III

Hello @JustinColville ,

Has this known issue been fixed? Thank you!

0 Kudos
JustinColville
Esri Contributor

@LearnThenShare Unfortunately, this issues has not been addressed.  We are working with the Maps SDK team to try to address it, but I do not have a timeline of when this will be fixed.

0 Kudos
AshleyPeters
Occasional Contributor III

Thanks Justin! I've got labeling turned on, so it works around the issue. I had assumed it was a known issue, just couldn't find it mentioned anywhere. Thanks again!

0 Kudos
BobbyS
by
New Contributor

Hi Ashley,

Can you let us know how you set up the labeling to circumvent the bug?  Thanks so much!

0 Kudos
BobbyS
by
New Contributor

You can disregard...I figured it out.

I created a simple circle symbol with white background and then setup a label with an Arcade expression to populate the label.  Here is the Arcade expression I used:

Upper(Left($feature["created_user"],2))
 
Thanks!
0 Kudos
AshleyPeters
Occasional Contributor III

Hi Bobby,

We were using some trial licenses at the time so I can't easily go back and look at the map and the data. Looking back at what little I do have, I believe I used the Full Name column to label. The symbology kept the "AF", but each person's name showed directly above the symbol.

Hope this helps!

Ashley

0 Kudos