Field Maps Freezing

2430
18
03-31-2022 04:05 PM
AW_Grove
Occasional Contributor

Since the Field Maps iOS update on 3/28/22 to Version 22.1.0 many (8 so far) of our users are experiencing the Field Maps app freezing on them when trying to use an offline map. When we remove the map and redownload the freezing issue appears to resolve. We have never experienced this issue before on iOS. 

 

Is anyone else experiencing this issue? Any tips?

18 Replies
by Anonymous User
Not applicable

We are experiencing similar freezing for our field teams though it is not everyone. After a few hours of testing yesterday, it did seem that it might be related to the GPS connection. The freezing seemed to be more frequent with devices that had a Trimble connection configured even if they were not using it. Removing the Trimble connections from the device did seem to fix the problem at least during the hour we tested afterwards. We have had issues with Trimble and Field Maps in the past. Updating the firmware on the Trimble units fixed those. So we are going to try that next. 

0 Kudos
AW_Grove
Occasional Contributor

Thanks for sharing! Most of our field users don't have Trimble configurations set, however they all do have the Trimble Mobile Manager app installed. We will keep an eye out for users using GNSS devices and I will update the post if we see the same. 

The good news (so far) is that removing all previously downloaded maps and redownloading seems to fix the issue. We are thinking there may be something in the new version of Field Maps that previously downloaded maps are incompatible with. 

0 Kudos
by Anonymous User
Not applicable

Let me know if that works. Our field teams remove and download new work areas every morning (or at least they are supposed to). So we were still having the issue on those devices which were freezing. We do have Collector also installed on those devices since we are just now making the push to field maps throughout the organization. They may have still had a downloaded area in Collector. Wonder if that might also be an issue though I believe the two apps pull from different locations. 

 

0 Kudos
AW_Grove
Occasional Contributor

Interesting. Maybe our fix is just temporary then. I will update if the same users come back with the issue again. They are suppose to download a new map weekly, but we have definitely come across some downloads that are months old. 

I wouldn't think the Collector install would contribute to the issue. It is a separate app and the basemaps/sdks are sourced from a completely separate folder. For your troubleshooting reference - we don't have any users with Collector installed. 

HaleySiebert
Esri Contributor

I'm sorry you're encountering this issue! If you're able, you can share your map with the user arcgisfieldmaps, and I can try to learn more about the issue on my end. (If you're unfamiliar with sharing across organizations, this link walks you through the process.)

0 Kudos
by Anonymous User
Not applicable

I will need to get permission from my clients. We have NDAs that do not allow us to share data. 

0 Kudos
AW_Grove
Occasional Contributor

Hi @HaleySiebert - I have given you access through the arcgisfieldmap user. I will DM you with more details. I don't think (at least for our use case) you will be able to replicate the problem. It seems like anything downloaded prior to the FM update is broken, everything downloaded after the FM update is working. It sucks, but it looks like our best solution is to just reach out to 260 users to have them redownload. 

0 Kudos
Rural_Design_LimitedGIS
New Contributor III

Having the same issues, for the last week or so Fieldmaps have been so glitchy on our Trimble TDC600 that it's driving nuts!!! User's can't seem to download offline areas or collect features on sites anymore...works for some projects and then for no reason doesn't work on another (all configurations are the same).

Assuming something to do with the newest update...has anyone found a solution for this?

by Anonymous User
Not applicable

We assume it is something to do with the new version as well since we did not have this problem with the past build. Really wish there was a way to revert back to the old version in iOS. For those having issues we have been reverting them back to Collector sadly. 

0 Kudos