Field Maps Cumulative Lag

1933
26
04-13-2021 03:09 PM
LaurenHarter
New Contributor

My team is experiencing a lag in Field Maps that builds up; as more data are collected, the app gets slower until there is a 20-30 second lag after each "click" in the app. This is happening to most or all members of our team. For most people, shutting down and reopening Field Maps when it begins to slow down solves the problem. For at least one person, nothing seems to help, including clearing the cache, clearing out any unnecessary files and programs on the tablet, uninstalling and reinstalling Field Maps, and finally doing a factory reset of the device.

Any other suggestions would be appreciated. We are using Samsung Galaxy Tab Active2 tablets with Android version 9 OS.

0 Kudos
26 Replies
ColinLawrence
Esri Regular Contributor

Hi @LaurenHarter ,

Thank you for reporting this. I have a Tab Active 2 as well that I can do some testing on. I have a few questions for you to help us troubleshoot what might be going on:

- First, what version of Field Maps are you currently using? A new version (21.1) should be hitting the app store as early as tomorrow. Please test with that version and let me know if your crew reports the same issues.

- When did you start noticing this behavior?

- Can you tell me more about the data you are consuming in Field Maps; where is it hosted?

- What actions are being performed in your daily routines? (i.e. are you adding new point features, streaming line features, editing existing polygons, etc)

 

Regards,

Colin

0 Kudos
TravisSizemore
Occasional Contributor

Hi Colin, 

I'm the GIS Specialist for Lauren's team. I'm trying to help them get to the bottom of this. To answer your questions:

1. They are all updated to the newest version of Field Maps that was released last week. The issue still remains.

2. They started noticing the behavior just a few days into the field season as data began to accumulate (a few thousand features at that time). They are still experiencing this issue on the tablets; however, their iPhone and Android phones seem to work fine (except for one case of recent values not showing up). 

3. The web map they are pulling from includes 17 layers (points, lines, and polygons) and one table that are from 5 hosted feature services and one hosted view with a time filter enabled (shows last 16 hours of data). The data they are collecting goes mainly into one feature service with 7 layers and one table. They will create tens of thousands of features throughout the season. In the past, using Collector, we haven't had issues with this. I can invite you to the group with this content if you want to take a closer look.

4. They are doing all the actions you described, but mostly adding just points and lines. 

Thanks for your help,

Travis

0 Kudos
ColinLawrence
Esri Regular Contributor

Thanks for getting back @TravisSizemore . I am happy to take a look at your data if you can share it with us. You can share the data and map to a group and invite the user 'arcgisfieldmaps'. Let me know here or in a DM when shared and note the Group name so I can easily find it. 

You mentioned tablets and Lauren mentioned Tab Active2s specifically. Is this also happening on iPads or any other tablets?

 

Colin

0 Kudos
TravisSizemore
Occasional Contributor

Hi Colin,

Sorry, I didn't see your response until now. I just added you to our group F02_BPM_admin. The map in question is called F02_BPM_2021_WM_collect. 

@LaurenHarter can answer this better, but I think the Tab Active2 is the only device having this issue. And I think it's not all of them, but more than one. 

Thanks, 

Travis

0 Kudos
BenWalker1
New Contributor III

Any update?

0 Kudos
LaurenHarter
New Contributor

Travis is correct, not all of our team members are having problems on the Tab Active2 but several are. Some have found that just shutting off the tablet when not in use prevents lag issues, but others haven't found any solutions and are using Field Maps on cell phones. We haven't had any lag issues with cell phone users.

0 Kudos
Ewout_de_Graaff
New Contributor III

Dear Colin,

We experience the same problems with iPads (iPad Air 2 gen, iPad Air 3 gen, iPad Pro 11 2 gen). Because our field workers have to do a relatively large number of edits per day, it is not uncommon for the iPad to be restarted 5 to 10 times a day to save the Field Maps edits in less than 15 seconds. Else they spend their time waiting 30-60 seconds for an edit to save.

In particular, there are 2 web maps where we experience the problems (also the 2 most actively used web maps within the organization at the moment).

Let me know if you would like to take a look at this too, then I invite "arcgisfieldmaps" too.

GIS specialist bij Terra Nostra
0 Kudos
KevinMorris2
New Contributor III

I experience this same behavior mapping trails at high data density (1-2 ft) setting. At ~ 1/2 mile it starts to get sluggish. At 1 mile it might just hang and I'll loose all my trail data. Behavior seen on all my android devices including Nokia 6.1 (phone), Samsung Tab 2, Samsung Tab3, Samsung Active Tab2. The worst issue is the data loss. Without fail, I'll loose data on 80% of my field trips, due to this issue or another where I need to take a photo and Field Maps blips away. I'm going to post on asking to store data permanently when collecting lines, etc.

0 Kudos
ColinLawrence
Esri Regular Contributor

@TravisSizemore Can you double check the Group F02_BPM_admin is shared with arcgisfieldmaps? I do not see an invitation. I should be able to test this out next week for you. 

If you have not already, I would consider opening a Support case as well.

Regards,

Colin

0 Kudos