How do I Deploy dev edition Experience as Azure Static Web App?

97
1
05-20-2020 05:29 PM
KirkKuykendall2
Occasional Contributor

I built an azure static web app using the "no framework" option in the quickstart:

Quickstart: Building your first static web app with Azure Static Web Apps | Microsoft Docs 

With ExB 1.0, I built an experience that included the simple widget.  

I downloaded the zip of the experience, and deployed the files to my localhost running IIS.  It works there.

I copied all the files from the zip into the repo, then pushed to github.

The build action triggered by the push shows this error:

Using Hugo version:
34Hugo Static Site Generator v0.59.1-D5DAB232 linux/amd64 BuildDate: 2019-10-31T15:21:02Z
36Error: module "themes/default/" not found; either add it as a Hugo Module or store it in "/bin/staticsites/ss-oryx/app-int/themes".: module does not exist

It looks like Azure uses linux for this, is the experience deployable to linux?

If not what changes would be needed?

Thanks!

0 Kudos
1 Reply
AndyEgleton
New Contributor

Hi @KirkKuykendall2 

I also encountered this issue, it seems to be related to the Azure deployment detecting the content of the ESRI experience as being a type of Hugo website and attempting to build it as such. I've opened an issue here to try and resolve that.

In the meantime, a quick work around is to place the experience in a subfolder, and include a basic index.html file in the root with a redirect to your app (e.g. Javascript redirect). Redirects work with relative paths so no issues with the Azure urls.

0 Kudos