Using Expression in Embed Widet in Experience Builder (enterprise edition)

1837
11
Jump to solution
11-18-2020 03:46 PM
Labels (1)
AzinSharaf
Occasional Contributor II

I am using Experience Builder in ArcGIS Enterprise 10.8.1. In Embed Widget, how can I use the expression?

I need to concat my url with GlobalID field. I can't make it work.

AzinSharaf_0-1605743018134.png

 

 

1 Solution

Accepted Solutions
Shengdi_Zhang
New Contributor

Hi Azin,

Please try to use quotation marks around the static text.

Shengdi_Zhang_0-1605753471417.png

Shengdi

View solution in original post

11 Replies
Shengdi_Zhang
New Contributor

Hi Azin,

Please try to use quotation marks around the static text.

Shengdi_Zhang_0-1605753471417.png

Shengdi

AzinSharaf
Occasional Contributor II

Thank you Shengdi. It is working now.

I couldn't copy the URL from the clipboard into the Expression so I typed all the long url. This is a different issue.

BrunoSousa1
New Contributor III

I don't know why we can't paste text inside expressions. I've had to type hundreds of characters already and it's a pain...

TonghuiMing
Esri Contributor

@BrunoSousa1 The reason, to put it simply, is that the copy & paste function does not only evlove the strings/codes themselves that we can see from the UI but also needs to support the data source structure behind it if evolved, e.g. getting the field id from multiple data sources, etc.

We are working on these kinds of enhancements to provide a better user experience in the future. Thanks for staying with us.

 

Best,

Tonghui

DavidMurray_ODWC
New Contributor III

Another little snag is that all the text displayed by esri is sans serif.  So me typing in "...jRf8jjFwxedITdFe/arcgis/rest/services..." (or whatever address) becomes annoying when that l is really an I, or vice versa.

0 Kudos
MatthewCriel
New Contributor III

Is the embed widget still being enhanced?  I want to connect it with multiple data sources and multiple fields within a feature.

 

Thanks!

0 Kudos
rachelm
New Contributor III

I have tried this for the URL link on a Button widget, and I cannot save the application after adding the dynamic field.  So my parameter isn't passed in. Technically this should work but I can't get this to save in order to test it out. 

@Shengdi_Zhang any idea how to deal with this?

(Workflow is passing parameters to a webhook that will create a Survey123 report using the Rest api)

 

0 Kudos
ShengdiZhang
Esri Contributor

Hi, you were still in the editing state before you clicked the Insert button, so the Save button is not enabled.

0 Kudos
BrunoSousa1
New Contributor III

Btw, a friend of mine found a workaround for pasting strings into the expression. He just opened developer tools on the browser and found the html for the expression box and pasted the URL there. The pasted text shows up in the UI and you can save it from there.