Select to view content in your preferred language

Search Layer source using Search Widget

642
3
Jump to solution
07-31-2022 12:44 PM
Mento
by
New Contributor II

So, in my app, I'm using two sources for searching one which uses layer sources and another uses geocoding. The geocoding works properly. However, for the layer source, I'm searching by the CMANAME. When I type either Toronto/Victoria, it doesn't properly pan/zoom to it. Sometimes the CMANAME (Toronto/Victoria) won't even appear after I type. Can someone tell me why it properly doesnt pan/zoom to the extent and why the name doesnt appear when i type it in

 Screenshot for Panning/Zooming. The Average Home Values is the layer being used by the map

Charanb98_2-1659296401211.png

Search setting for the layer source

Charanb98_1-1659296286749.png

When I type Victoria, only the Geocode source shows up, it should also show the other layer source name 

Charanb98_3-1659296533393.png

Average Home Values dataset

Charanb98_0-1659296261359.png

 

0 Kudos
1 Solution

Accepted Solutions
ShengdiZhang
Esri Regular Contributor

Hi @Mento ,


However, for the layer source, I'm searching by the CMANAME. When I type either Toronto/Victoria, it doesn't properly pan/zoom to it.

This is a known bug, that the map does not zoom to the correct extent when there are multiple trigger data.

 

When I type Victoria, only the Geocode source shows up, it should also show the other layer source name 

I can't reproduce this issue, can you provide a sample app?

 

Thanks,

Shengdi

View solution in original post

0 Kudos
3 Replies
ShengdiZhang
Esri Regular Contributor

Hi @Mento ,


However, for the layer source, I'm searching by the CMANAME. When I type either Toronto/Victoria, it doesn't properly pan/zoom to it.

This is a known bug, that the map does not zoom to the correct extent when there are multiple trigger data.

 

When I type Victoria, only the Geocode source shows up, it should also show the other layer source name 

I can't reproduce this issue, can you provide a sample app?

 

Thanks,

Shengdi

0 Kudos
Mento
by
New Contributor II

@ShengdiZhang so I can only use one trigger action in order for it to work properly? Also, could you provide me ur email so I can add you to the group and share it

 

0 Kudos
ShengdiZhang
Esri Regular Contributor

This is because there are two trigger data. Currently, zoom to and pan to actions only work correctly when only one trigger data exists.

My username is she10946.

0 Kudos