Not Sorting Order As Numeric in List Widget ExB Developer Edition

676
6
05-23-2022 04:55 AM
HasanHöl
New Contributor II

Hi Everyone,
I am using Experience Builder 1.8 Developer Edition and ArcGIS Enterprise 10.6.1.

In List Widget, I want to sort with ascending numeric but list widget is not working ascending numeric order as you see in the first screenshot.

What am I doing wrong? or is there a bug about sorting in List Widget?

DATA_SORTING.JPG

LIST_WIDGET_SORTING.JPG

Thank you in advance.

Tags (2)
0 Kudos
6 Replies
ShengdiZhang
Esri Regular Contributor

Hi @HasanHöl 

I am unable to reproduce your problem using the data view or the list sorting tool. Can you help to check if sorting on other non-numeric fields of this data or numeric fields of other data does not work as well?

Regards,

Shengdi

0 Kudos
HasanHöl
New Contributor II

Hi @ShengdiZhang
Thank you for response.
I also checked sorting non-numeric fields as bus stop name field for the list widget. You can see the list sorting randomly for second character in the screenshot. I do not understand why this is happenning.

DURAK_ADI_SORTING.JPG

Is there any problems about relation between Portal for ArcGIS version and ArcGIS Experience Builder version? or configuration of Portal? I do not understand.

Regards,

Hasan Höl

0 Kudos
DanJiang
Esri Contributor

Hi @HasanHöl , 

We did a quick test with some sample data and cannot reproduce the issue. From your description, my best guess would be that the service you are using may not support sorting. Could you please check the data service from your side? You can open the query html of your service and fill the highlighted inputs (see the attached screenshot as an example), then click "Query(GET)" button at the bottom to check whether the returned features are in the correct order.  Hope this info can help. 

DanJiang_0-1653642099523.png

 

Best, 

Dan

0 Kudos
HasanHöl
New Contributor II

Hi @DanJiang 


I tested  the sorting problem and tried to figure out it. I don't still understand.


However, after your suggestion, I figured out that the best and simple solution is to create a new geodatabase in PostgreSQL, republish my map and configured web map in the Portal. Previously the spatial data was in Oracle database. I have no idea about any relation between two databases.

Now, I can sort the fields as I want.

Thank you for your response and help.

Best regards,

Hasan.

0 Kudos
DanJiang
Esri Contributor

Glad to know that the issue is finally solved!. 

 

Best, 

Dan

0 Kudos
DavidColey
Frequent Contributor

I have found that I get more consistent sort results when I create a view and apply the default sort on objectID. This works well if I am only using one attribute field as a sort option.  The sort becomes inconsistent if I try to then add more than one attribute as a sort option.

0 Kudos