Select to view content in your preferred language

Issues with selection of list items following a search

580
3
05-26-2022 08:48 AM
ANRGIS
by
Occasional Contributor

I am experiencing inconsistencies when selecting a record from a link following a search. We have a Big Tree Experience site that lists the trees in a list on the left (List1) and then based on a selection there, the map panel in the middle (Map1) and list component on the right (List2) respond on the selected records. This functionality works well until a search term is searched in List1. Once there is a search term entered and the list of items shows the results of the search, the selection of records in the list becomes inconsistent. Sometimes clicking a record selects the record and the other components react accordingly. Other times upon record click the selection seems to stay for a short while and the other components start to respond, but then the selection does not stick and the experience behaves as if there is not a selected record.

The attached screen recording shows the behavior when there is not a search term and then the unexpected behavior when there is a search term. Any help is resolving this is appreciated!

 

Tags (3)
0 Kudos
3 Replies
ShengdiZhang
Esri Regular Contributor

Hi @ANRGIS ,

If you entered "Maple" instead of "maple" in the search input box in list 1 and can't reproduce this issue, I think it's for the same reason as this post. And we plan to fix this issue in the next release.

Thanks,

Shengdi

0 Kudos
ANRGIS
by
Occasional Contributor

If I search using the term "Maple" I get the expected behavior. Looks like it is that case sensitivity issue. Good to know the fix is coming, thank you!

0 Kudos
ShengdiZhang
Esri Regular Contributor

Hi, this bug should be fixed in today's update.